DX Infrastructure Manager

Expand all | Collapse all

Failed to send set_hub to spooler (communication error)

Jump to Best Answer
  • 1.  Failed to send set_hub to spooler (communication error)

    Posted 12-02-2019 01:10 AM
    Hi Team,

    Can i know what this error means.
    Failed to send set_hub to spooler (communication error)

    Below is the transaction log i capture from spooler log:
    Dec 1 15:05:52:211 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 15:18:39:455 [139682624210752] spooler: SSL requested but not enabled, closing connection from 10.87.10.249/37992 Dec 1 15:18:39:455 [139682624210752] spooler: SSL requested but not enabled, closing connection from 10.87.10.249/37994 Dec 1 15:18:39:456 [139682624210752] spooler: SSL requested but not enabled, closing connection from 10.87.10.249/37996 Dec 1 15:18:39:456 [139682624210752] spooler: SSL requested but not enabled, closing connection from 10.87.10.249/37998 Dec 1 16:05:53:993 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 17:05:54:792 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 18:05:55:544 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 19:05:56:293 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 20:05:58:000 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 21:05:58:747 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 22:05:59:461 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 23:06:00:197 [139682505950976] spooler: QueueAdmin - expire old messages Dec 1 23:35:53:925 [140019470169920] spooler: ########## START ########## Dec 1 23:35:53:925 [140019470169920] spooler: Robot Spooler 7.93 [Build 7.93.9350, Oct 31 2017] Dec 1 23:35:53:925 [140019470169920] spooler: CA Dec 1 23:35:53:925 [140019470169920] spooler: PID=14139, loglevel=0 Dec 1 23:35:53:925 [140019470169920] spooler: robot=plgsasam1plcy20.livdmz2.r1.aig.net domain=AIG Dec 1 23:35:53:925 [140019470169920] spooler: spooling=off flush_timeout=900 flush_priority=5 flush_records=1000 Dec 1 23:35:53:925 [140019470169920] spooler: expire=604800 Dec 1 23:36:14:156 [140019470169920] spooler: flushing is set to ON, hub=10.87.68.9 port=48001 Dec 2 00:35:54:650 [140019351910144] spooler: QueueAdmin - expire old messages


  • 2.  RE: Failed to send set_hub to spooler (communication error)
    Best Answer

    Posted 12-02-2019 07:38 AM
    What SSL mode is the hub set to?

    What version of robot is running?

    KB Article regarding: Failed to send set_hub to spooler (communication error)

    https://ca-broadcomcsm.wolkenservicedesk.com/wolken/esd/knowledgebase_search?articleId=47839

    You can also try:

    - Stop the robot watcher service
    - Make a backup copy of the nimsoft directory
    - remove nimsoft from the machine
    - reinstall the robot and any needed probes
    - reapply saved off .cfg files to needed probes
    - start up robot watcher

    This error is generally benign. Unless you're seeing other issues with this robot (or other robots on this hub), it can usually be safely ignored. With compatibility mode set on the hub, it allows for SSL and non-SSL traffic (some probes can use SSL while others can't). The message in the log indicates that 'something' is trying to use SSL and failing. However, with compatibility mode, it will send that traffic without having to use SSL. It's a 'warning' type of message.

    Steve

    ------------------------------
    Support Engineer
    Broadcom
    US
    ------------------------------