DX Infrastructure Management

Expand all | Collapse all

Upgrading from UIM 8.3.1 to 8.5.1

  • 1.  Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-29-2019 11:14 AM
    Folks,

    We are upgrading from 8.3.1 to 8.5.1.  We are installing new vm's for the new infrastructure and will migrate all customers to the new primary.  I have a couple of questions and any comment/suggestions are welcome.

    1) How do we add a new primary hub into the current domain without affecting the current primary so that we can migrate the current customer hubs to it?

    2) We will be installing a  new DB server for 8.5.1, do we need to worry about migrating data from the old db to the new one? Will there be any problems with going to a new db without migration?  We will be moving from MSSQL to MySQL.

    3) Are the table layout changes between 8.5.1 and 8.3.1 that would require a conversion should we decide to migrate db data?

    4) Will we need to deploy new robots to all customer hubs and their robots? What is the best way to do that deployment?

    5) Is there a way to migrate probe customizations from 8.3.1 to 8.5.1?

    6) Is there a way to migrate Security Access Control Lists from 8.3.1 to 8.5.1?


    Any help or suggestions are welcome. If you think there is something I'm overlooking, please let me know.

    Thanks


  • 2.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-29-2019 03:58 PM
    See answer below

    1) How do we add a new primary hub into the current domain without affecting the current primary so that we can migrate the current customer hubs to it?

    Answer: if you install with the same EXACT domain name when doing the install and point to a new database instance or schema name then you can share the security.cfg file between them and move the hubs as needed.



    2) We will be installing a  new DB server for 8.5.1, do we need to worry about migrating data from the old db to the new one? Will there be any problems with going to a new db without migration?  We will be moving from MSSQL to MySQL.

    Answer: we do not support migrating data from one database type to another you will need to do a clean install

    3) Are the table layout changes between 8.5.1 and 8.3.1 that would require a conversion should we decide to migrate db data?

    Answer: Yes there are schema changes between 8.31 and 8.51. We do not support any type of cross-database migration.

    4) Will we need to deploy new robots to all customer hubs and their robots? What is the best way to do that deployment?

    Answer: I would suggest updating all client hubs and robots to version 7.93 hub and robot including your primary BEFORE the upgrade/migration.
    Make sure this is all working as expected and then do the upgrade/migration

    5) Is there a way to migrate probe customizations from 8.3.1 to 8.5.1?

    Answer: the probe configuration are stored in the local .cfg file for probes on local robots for the most part. You would need to provide exact probes you have questions about for us to provide you more details.



    6) Is there a way to migrate Security Access Control Lists from 8.3.1 to 8.5.1?
    Answer: see option 1 above you could also use the below KB article if you have a windows hub:
    https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=43713

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 3.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-29-2019 04:29 PM
    4) Will we need to deploy new robots to all customer hubs and their robots? What is the best way to do that deployment?

    Answer: I would suggest updating all client hubs and robots to version 7.93 hub and robot including your primary BEFORE the upgrade/migration.
    Make sure this is all working as expected and then do the upgrade/migration

    PLUS: For the migration you can follow these steps to move the robot to the new domain:
    a) Stop the robot;
    b) Change the robot.cfg (domain, hubip, hub, hubrobotname)
    c) Start the robot

    In the past I did a shell script that move the robots from one domain (8.4 uim version) to a new domain (8.5.1 uim version) using probe utility. The script did the changes at robot.cfg and then restart the robot. It worked like charm.


  • 4.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-29-2019 04:35 PM
    >1) How do we add a new primary hub into the current domain without affecting the current primary so that we can migrate the current customer hubs to it?
    >
    >Answer: if you install with the same EXACT domain name when doing the install and point to a new database instance or schema name then you can >share the security.cfg file between them and move the hubs as needed.

    So we can have two primary hubs running in a domain at the same time without issue?


  • 5.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-29-2019 04:57 PM
    If pointing to two different database instances/schemas yes.

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 6.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-29-2019 11:49 PM
    One more question (I hope), we have our primary and second hubs.   So basically, in the below, how do we move customer hubs/robots from the Current Primary Hub to the New Primary Hub so that all the paths get updated correctly?  Is there a doc that describes this process?

    <Domain>
    <New Primary Hub>
    <New Secondary Hub>
    <Current Primary_Hub>
      --> probes
    <Current Secondary_Hub>
     ==> probes
    <Customer1Hub> 
     ==> robot 1
         ==> probes
     ==> robot 2
         ==> probes
    <Customer2Hub>
     ==> robot 1
        ==> probes
    ...


  • 7.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-30-2019 09:46 AM
    So basically the process would be to set up the new primary.
    Then if you are using tunnels set up tunnels to your secondary hubs.

    then when ready to go live with the new primary disable the get queues on the old primary and create and enable the same ones on the new primary.

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 8.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 10:16 AM
    Is there a way via script, preferably, to pull the config info for a probe?  With pu I can get probe info but not probe config.


  • 9.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 10:23 AM
    You should use the pu of controller probe "probe_config_get" to get probe config and "probe_config_set" to pull the config.


  • 10.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 11:23 AM
    get_info works but when I try probe_config_get, I get the below:

    probe_config_get failed: command not found


  • 11.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 10:34 AM
    you can via the console open a probe config file
    in IM select the probe then Ctrl + N. 

    or 
    https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=34707

    ------------------------------
    Support Engineer
    Broadcom
    ------------------------------



  • 12.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 28 days ago
    Questions about migration. I'm still not sure I understand the migration process. I'm basically doing a complete new install and I want to copy as little as possible from the current core hub. 

    1) do I have to change every robot? If so, what?
    2) what changes are needed on secondary/customer hub?
    3) is there a good doc on tunnels and queues? I don't understand how it all works. 
    4) other than robots and hubs, is there anything else that needs changed?


  • 13.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-29-2019 04:37 PM
    Any chance we could see your script?


  • 14.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 07-30-2019 10:48 AM
    Yes. I just have to remove some extra functions that was used and don't make sense anymore.
    I will upload here as soon as possible.


  • 15.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 10:14 AM
    Did you upload your script?  Thanks!


  • 16.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 10:25 AM
    No, I didn't.
    Sorry, I will try to upload this week.

    For security reasons, I can't upload any data from my company desktop, so I have to access the community forum at home to upload the file.


  • 17.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 11:30 AM
    I would appreciate it.  This has been dropped on me, without any training, so I'm doing my due diligence to get us to a supported version.


  • 18.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 28 days ago
    Have you upload? I haven't seen anything yet.


  • 19.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 10:13 AM
    I was looking at release notes for 8.5.1 and it lists 7.80 as the robot version but you mentioned 7.93.  Is there a current list that has the probe versions for 8.5.1? I want to check what version of each probe we are currently running against what is the most current version in 8.5.1.

    Thanks, as always!!


  • 20.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-14-2019 10:27 AM
    it is unlikely the documentation for 8.51 will be updated again. 
    Unless specifically stated in the probe release notes they fully compatible with 8.51. 
    robot & hub up to 7.97HFxxx is fully compatible with 8.51.

    ------------------------------
    Support Engineer
    Broadcom
    ------------------------------



  • 21.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 08-15-2019 01:47 AM
    Example pu for probe_config_get: (change the names between () )
    pu -u administrator -p xxx /(domain)/(hub)/(robot)/controller probe_config_get cdm (robot) ""


  • 22.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 22 days ago
    Gene,

    If we are going from MSSQL to MSSQL (newer version), then we could migrate data from old to new?  Is there a reason we might want to migrate that rather than start with a clean DB?  How would we handle the migration with schema changes?

    I really appreciate all your help.


  • 23.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 22 days ago
    Please see my first response.
    We do not support database to database migration.
    Either you will do an in-place upgrade or you can do a clean install.
    there is no other supported option.

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 24.  RE: Upgrading from UIM 8.3.1 to 8.5.1

    Posted 22 days ago
    I wasn't sure if that was only between different db types which is why I asked.