DX Infrastructure Manager

  • 1.  alarm_enrichment probe is not starting after DB migration

    Posted 07-26-2018 06:35 AM

    Hi,

     

    We migrated uim database from VM to Physical server. After that we edited  data_engine cfg as per new db server details and tested connection we were able to make connection with DB. But alarm_enrichment probe was not starting, got below error in alarm_enrichment probe.

     

     

     
    Jul 25 17:42:46:866 [main, alarm_enrichment] ****************[ Starting ]****************
    Jul 25 17:42:46:867 [main, alarm_enrichment] 8.56
    Jul 25 17:42:47:330 [main, alarm_enrichment] CmdbJdbcDataSource: ORA-01033: ORACLE initialization or shutdown in progress
     
    Jul 25 17:42:47:330 [main, alarm_enrichment] (1) error, Failed to connect to database: ORA-01033: ORACLE initialization or shutdown in progress
     
    Jul 25 17:42:47:333 [main, alarm_enrichment] (1) error, Failed to connect to database: ORA-01033: ORACLE initialization or shutdown in progress
     
    at com.nimsoft.probe.service.enrichment.cmdb.CmdbJdbcDataSource.connectToDatabase(CmdbJdbcDataSource.java:113)
    at com.nimsoft.probe.service.enrichment.cmdb.CmdbJdbcDataSource.initialize(CmdbJdbcDataSource.java:57)
    at com.nimsoft.probe.service.enrichment.cmdb.CmdbCacheEnrichmentSource.createDataSourceHandlerForConfigEntry(CmdbCacheEnrichmentSource.java:191)
    at com.nimsoft.probe.service.enrichment.cmdb.CmdbCacheEnrichmentSource.initialize(CmdbCacheEnrichmentSource.java:122)
    at com.nimsoft.probe.service.enrichment.cmdb.CmdbCacheEnrichmentSource.readCmdbSection(CmdbCacheEnrichmentSource.java:66)
    at com.nimsoft.probe.service.nas.alarmenrichment.AlarmEnrichmentService.loadEnrichmentSources(AlarmEnrichmentService.java:96)
    at com.nimsoft.probe.service.nas.alarmenrichment.AlarmEnrichmentService.<init>(AlarmEnrichmentService.java:40)
    at com.nimsoft.probe.service.nas.Nas.postLoginInitialization(Nas.java:420)
    at com.nimsoft.probe.service.nas.Nas.login(Nas.java:372)
    at com.nimsoft.nimbus.NimProbeBase.nimAttachProbe(NimProbeBase.java:303)
    at com.nimsoft.nimbus.NimProbe.initSubscribe(NimProbe.java:572)
    at com.nimsoft.nimbus.NimProbe.doForever(NimProbe.java:416)
    at com.nimsoft.probe.service.nas.Nas.run(Nas.java:565)
    at com.nimsoft.probe.service.nas.Nas.main(Nas.java:348)
    Resolution:
    Please check and change db name and port in enrichment_source raw configuration as per new new db server..


  • 2.  Re: alarm_enrichment probe is not starting after DB migration

    Broadcom Employee
    Posted 07-26-2018 12:09 PM

    Hi Pavan,

     

    If I understand correctly you managed to fix this problem by performing the changes under the Resolution section.

     

    Could you please confirm this is correct so I can convert this question into a document?

     

    Thanks,

    Alex



  • 3.  Re: alarm_enrichment probe is not starting after DB migration
    Best Answer

    Posted 07-27-2018 02:27 AM

    Hi Alex,

     

    Yes, You are correct. Issue got resolved by performing changes in Resolution section (In NAS raw configuration).

     

    Please convert it into document.

     

     

    -Pavan