DX Infrastructure Manager

Expand all | Collapse all

a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

  • 1.  a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

    Posted 11-16-2018 06:31 AM

    a server is put in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).



  • 2.  Re: a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

    Broadcom Employee
    Posted 11-19-2018 02:33 AM

    You need to place your application devices into maintenance (don't place robots which monitors your application)



  • 3.  Re: a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

    Posted 11-19-2018 02:53 AM

    How can i do that ? Can you please help .

    I have made a group of 520 servers(robots) and dragged this group to maintenance schedule.

    Alerts of these servers are not visible on UIM but are forwaded to Moogsoft.



  • 4.  Re: a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

    Broadcom Employee
    Posted 11-19-2018 03:49 AM

    Sorry I did not understand the question clearly.

    How did you configure UIM alert forwarding to your application ?



  • 5.  Re: a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

    Posted 11-19-2018 06:27 AM

    We have integrated UIM and Moogsoft , configured UIM using attach queue in central hub server so that alerts generated in UIM gets forwaded to Moogsoft for event management.



  • 6.  Re: a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

    Broadcom Employee
    Posted 11-19-2018 06:42 AM

    So It sounds that UIM maintenance mode does not affect that described integration flow.

    Need confirmation who has done the integration. Cheers

     



  • 7.  Re: a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

    Broadcom Employee
    Posted 11-19-2018 08:44 AM

    Based on your last reply about using an attach queue that is forward the alarms to  Moogsoft the answer would be no maintenance would not affect that.

     

    probes send out a message with a subject of alarm. This is picked up by the alarm_enrichment probe and processes then sent back out on the wire as alarm2. NAS then picks this up and this is where maintenance comes in and NAS will suppress it.

     

    if you are sending alarms with alarm subject over to Moogsoft this process has not completed as of yet and is why it is failing.

     

    if you can change the subject message that you are using I would suggest creating an AO profile that posts alarm message to a new subject such as alarm3 or MoogsoftAlarm and have your queue forward this message over that have already been through NAS maintenance mode process.

     

    If you can not do that for some reason you would need to open an enhancement request to have dev look into some other solution.



  • 8.  Re: a server is in maintenance mode through ump, will moogsoft still receive alerts generated by that server. UIM - Moogsoft integration done through LAM(Link Access Module).

    Broadcom Employee
    Posted 11-19-2018 08:41 PM

    Just a follow up one important part.

    To maintenance to work, NAS probe have to be part of the flow.

    Your behavior indicates that NAs probe does not come into the picture in your integration flow.