DX Infrastructure Manager

Expand all | Collapse all

interface_traffic reverted to 32-bit counters with upgrade?

  • 1.  interface_traffic reverted to 32-bit counters with upgrade?

    Posted 05-19-2017 06:37 PM

    We upgraded to interface_traffic 5.45 a little while ago, and now we are seeing that our interface usage graphs are completely wrong. It seems likely that the probe us using the OIDs for the 32-bit interface counters rather than the 64-bit interface counters. We were running a pretty old version before upgrading, so I'm not sure how recently this issue might have been introduced into the probe.

     

    Anyone else seeing this problem? Or anyone seeing it work properly with high-volume interfaces that can't rely on 32-bit counters?

    Thanks,

    Keith



  • 2.  Re: interface_traffic reverted to 32-bit counters with upgrade?

    Posted 05-23-2017 03:50 PM

    The plot thickens...

     

    Looking through interface_traffic.log (at loglevel 3), the probe indicates it is using the 64-bit counters. I extracted a series of several reported values for those counters and compared them to the QoS, and they are completely off. I can't see any pattern thus far.

     

    Let me know if you're seeing any issues with QoS from interface_traffic. Thanks!



  • 3.  Re: interface_traffic reverted to 32-bit counters with upgrade?

    Posted 06-06-2017 10:38 AM

    Hello Keith, can you please open a support case for this.

     

    Thanks and kind regards,

    Britta Hoffner



  • 4.  Re: interface_traffic reverted to 32-bit counters with upgrade?

    Posted 06-06-2017 11:36 AM

    I did open a case. I posted this as I was doing my research so that I would have enough information to open the case. Thanks.