DX Infrastructure Manager

Expand all | Collapse all

Nas replication failure from client hub to primary hub

Jump to Best Answer
  • 1.  Nas replication failure from client hub to primary hub

    Posted 11-07-2016 08:51 AM

    Hi All, 

     

    I am using replication and forwarding in NAS to forward the alarms from my client HUB to Primary hub.

     

    I have a tunnel server in between. Replication queue are created between NAS client and Primary but i am not able to see any alarms on Primary. While investigating i found NAS queues are getting stuck at client NAS.

     

    Specific Error in logs:

    replExporter: POST_QUEUE_COMM_ERROR destination: CSC-PRI-MDS001 dest_addr: /CSC-EMEA-CLOUD/CSC-PRI-MDS001/cscncrmdc602-pr/nas sendTime: 0 ms timeout:30s

     

    Searched everywhere but could not find anything useful. NAS version 4.91

     

    Everything else in my environment seems to work fine. Any suggestion 

     

    Also was wondering what ports does NAS to NAS replication works on ?

     

    Thanks

    Sadashiv



  • 2.  Re: Nas replication failure from client hub to primary hub

    Posted 11-07-2016 11:49 AM

    Hello Sadashiv,

     What version of hub are you running?  Did you try using to use ATTACH and GET instead of POST queues to improve stability?

    Thanks.

     Regards

    -Sayeed



  • 3.  Re: Nas replication failure from client hub to primary hub

    Posted 11-07-2016 12:41 PM

    Hi Sayeed,

     

    I am running Hub 7.80HF14. 

    And yes when the replication is failing i have switched to GET and ATTACH mechanism and the rvironment is stable

    This error is from NAS.log while i am trrying use the NAS forwarding and replication feature i am not using any POST queues.

     

    This is what my intension here to find out what mechanism NAS forward replication works on ? Does NAS interanlly uses POST queus?

     

    Thanks
    Sadashiv



  • 4.  Re: Nas replication failure from client hub to primary hub

    Posted 11-07-2016 10:10 PM

    NAS replication uses a SQLite database to store the information that is to be replicated to the other server and the replication data is stored in queue in the form of tables . It uses a bulk import/export mechanism to read queues and export/import the information to replication folder on the second server and I guess it uses "post" to do that 



  • 5.  Re: Nas replication failure from client hub to primary hub

    Posted 11-10-2016 02:57 AM

    Hi Phani,

     

    Thanks for the answer, but what i am interested to know if the NAS uses 'post' mechanism to export/import the information it must be going through the tunnel communication if we have any in between a client and a primary Nimsoft hub.

     

    In my case i have a situation where everything within Nimsoft works(Tunnels, Get & Attach queues etc ) except NAS replication, this makes me keep wondering what could be the issue 

     

    All i get in logs when i enable Replication & forwarding :

    replExporter: POST_QUEUE_COMM_ERROR destination: CSC-PRI-MDS001 dest_addr: /CSC-EMEA-CLOUD/CSC-PRI-MDS001/cscncrmdc602-pr/nas sendTime: 0 ms timeout:3

     

    Wondering any specific ports needs to be opened or not as this is the error on client hub's NAS probe which connects to Primary via tunnel 

     

    Thanks

    Sadashiv



  • 6.  Re: Nas replication failure from client hub to primary hub

    Posted 11-10-2016 04:29 AM

    Both HUB's in same timezone? 



  • 7.  RE: Re: Nas replication failure from client hub to primary hub

    Posted 08-16-2019 07:16 AM
    Hi all,

    I found this coversation thread but the last question was never answered.

    How does it affect the NAS probe, in case that the primary hub and secondary hub are not in the same timezone?


  • 8.  RE: Re: Nas replication failure from client hub to primary hub

    Posted 08-16-2019 07:22 AM
    I think timezone does not matter, because nas uses offset value to adjust raw timestamp into local timezone timestamp.


  • 9.  RE: Re: Nas replication failure from client hub to primary hub
    Best Answer

    Posted 12-06-2019 06:50 PM
    Hello everybody!

    I solve this problem by recreating the 'QOS' queues, normalized after this action.

    Thank,

    Jorge Magrone



  • 10.  RE: Re: Nas replication failure from client hub to primary hub

    Posted 07-15-2020 01:25 PM
    Hi Team,

    So, what is the solution in case there is a Tunnel server in between remote NAS and primary NAS? Do we need to configure Queues (QoS & Alarms) instead of NAS Forward and Replication?

    Thanks,

    Jitendra Sharma


  • 11.  RE: Re: Nas replication failure from client hub to primary hub

    Posted 07-15-2020 02:48 PM
    Jitendra,
    This is from 2016 you really should start a new thread and hardly anything posted here will be the same
    If you are not doing any alarm manipulation at the client hub level it is best to use get attach queues and not nas replication especially if the client hub is not connecting directly to the primary hub via tunnel. IE connecting a middle-tier hub.
    The latency over multiple tunnel hopes is probably the problem here.
    You could replicate to the middle tunnel server and then forward alarms to the primary rather than trying to cross two tunnel connections.


    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------