Layer 7 API Management

Expand all | Collapse all

how to restore ssg_0_0.log

Jump to Best Answer
  • 1.  how to restore ssg_0_0.log

    Posted 12-28-2019 10:55 PM
    I am trying to build a new API Gateway server and test my installation step/process. I built the API Gateway and was able to bring it up. To test my installation process, I wanted to delete the node and wanted to follow the installation process again. So in menu, I selected option 2) Display CA API Gateway configuration menu and then 5) Delete the CA API Gateway.

    In the process, I accidentally removed ssg_0_0.log ( there was no reason for me to remove it, I accidentally removed it).

    I configured the Node again,using  Option 2, then 2. The node was created but the server wont_start. I do not know the reason as to why?  I couldn't figure out the problem because ssg_0_0.log was not created. I touched ssg_0_0.log file but still it is 0 size and it did not get populated.

    Q1) How can I restore ssg_0_0.log.  ( I can't access policy manager because Gateway is not yet up)
    Q2) Is the process to reset the correct ( Option 2 and option 5)? Or or there any other approaches to remove the node config?


  • 2.  RE: how to restore ssg_0_0.log

    Posted 12-29-2019 06:27 PM
    Hi,
    It might not be a problem of ssg log, sometimes when controller cannot launch gateway process, you won't see any ssg log.
    Therefore you may check controller log first,
    /opt/SecureSpan/Controller/var/logs/sspc_0_0.log

    Regards,
    Mark


  • 3.  RE: how to restore ssg_0_0.log

    Posted 12-30-2019 08:40 AM

    The node would not start, if I try to start again, this is the message that I see.
    Node start failed due to 'default could not be started: Node couldn't be started last time it was attempted; the PC will retry soon'.

    In /opt/SecureSpan/Controller/var/logs/sspc_0_0.log:, I see the below message repeating...
    07:29:58.386-0600 INFO 1 processcontroller.q: default starting
    07:30:03.387-0600 WARNING 1 processcontroller.q: default exited with status 0
    07:30:03.389-0600 WARNING 1 processcontroller.ProcessController: default crashed on startup with exit code 0
    07:30:03.389-0600 WARNING 1 processcontroller.ProcessController: default crashed on startup; copying its output:
    07:31:03.391-0600 INFO 1 processcontroller.ProcessController: default wouldn't start; restarting...
    07:31:03.391-0600 INFO 1 processcontroller.ProcessController: Getting API port from /opt/SecureSpan/Gateway/node/default/var/processControllerPort

    FYI: 2124 is the output of /opt/SecureSpan/Gateway/node/default/var/processControllerPort

     




  • 4.  RE: how to restore ssg_0_0.log
    Best Answer

    Posted 12-30-2019 01:53 PM
    Hi,

    If you are having problems starting the gateway and don't see anything written to the ssg_0_0.log then you can try to start it up with the following and you will see output going to stdout which should give some indication as to why the gateway is failing to start.

    /opt/Securespan/gateway/runtime/bin/gateway.sh start -console


    Hope that helps.

    Daren