It is mentioned within this page (https://docops.ca.com/display/MAG40/Prepare+for+Installation), that before installing MAG, the gateway should be upgraded to 9.2.
I have already installed OAuth Toolkit 4.0 even if I use the Gateway version 9.1. Is it absolutely necessary to have Gateway 9.2 for MAG 4.0? In that case, I guess I should choose the MAG 3.3.
Thanks in advance.
OTK 4.0 also requires Gateway 9.2. Below is our official supported versions.
Thanks for the response.
Nevertheless, I have already combined OTK version 4.0 with Gateway 9.1 and MAG 3.3 and trying to see if I can use all the available functions, before I need to upgrade the Gateway.
I have no problem in using the test clients, however when I try to access https://target.ca.com:8443/auth/oauth/v2/authorize/login (target.ca.com is my host name), I receive the error:
error: invalid_requesterror_description: Missing or duplicate parameters
I have found that in OTK 3.5, the problem was usually the value for otk_session_secret_encryption that needs to be exactly 256 bit was hyphenated and that it had to be modified. However, in OTK 4.0 this issue seems not to exist, as there are no hyphens in the value and anyway the policy cannot be modified, at least to my understanding.
Do you have maybe some idea what could be the problem (in case that Gateway 9.1 can cooperate with OTK 4.0).
OTK 4.0 is a major release (3.x to 4.x) that works on Gateway 9.2. MAG 4.0 is the corresponding major release for the Mobile API Gateway. The 4.0 releases provide a baseline that simplifies future upgrades, separating customer customization from policy updates and bug fixes. As you have noticed, this includes read-only policies.
Using OTK 4.0 with Gateway 9.1 is not supported. It is untested. MAG 3.3 is not compatible with OTK 4.0.
Thank you for the information regarding the compatibilities among them.