Automic Community

Expand all | Collapse all

DNA - PS_FILELOADER on Server 2016

Jump to Best Answer
  • 1.  DNA - PS_FILELOADER on Server 2016

    Posted 02-07-2020 09:27 AM
    Edited by Sarinas 02-07-2020 09:29 AM
    Hi,

    We are in the process of updating our environments to use W2016 and to 9.3.1.  We are having issues with the Fiserv job PS_FILELOADER, when we try to run it in the log files it showing:

    Looking for E:\Appworx\Remote_Agent\run\MB30-EWBATTS812\k6741882.00
    No Kill file found E:\Appworx\Remote_Agent\run\MB30-EWBATTS812\k6741882.00.
    Looking for E:\Appworx\Remote_Agent\run\MB30-EWBATTS812\k6741882.00
    No Kill file found E:\Appworx\Remote_Agent\run\MB30-EWBATTS812\k6741882.00.
    Looking for E:\Appworx\Remote_Agent\run\MB30-EWBATTS812\k6741882.00
    Kill file found.
    Kill file found.
    Process successfully terminated



    The 'Kill file found' was me killing the job manually through AM.  Every other job works fine but from my understanding PS_FILELOADER is one of the few if not the only one that calls additional sqts while running it, so I'm not sure if that is what's causing the issue.  There is also a NEWP*.LOG that I've never seen before that shows:

    (SQR 2507)   Incorrect.  Format for floating point number: [+|-]99.99[E99]
    Enter the file number:

    Is there any one else that runs W2016 and/or does any one know what the issue might be?


  • 2.  RE: DNA - PS_FILELOADER on Server 2016

    Posted 02-10-2020 10:13 AM

    Hi Jeremy,

    We also experienced issues with PS_FILELOADER when we went to Windows Server 2016.  In our case, it was when we introduced a new agent server.  First, we did not have a C:\Temp directory on the new agent server.  That solved the first issue, but then we saw inconsistent results on jobs finishing but not completing successfully.  We ended up attributing it to improper permissions for the Automic OS user on the C:\Temp directory and deleting the directory and re-creating it under the Automic OS user.  Not sure if this is related to your issue, but hope it helps.  If you want more specifics, let me know.

    Thanks,
    Dom




  • 3.  RE: DNA - PS_FILELOADER on Server 2016

    Posted 02-10-2020 11:21 AM
    Hi Dom,

    Thanks for the reply.  I have confirmed:
    • That the C:\Temp directory exists and to be sure was re-created by the Automic OS user (Appworx)
    • That the Appworx user has Full Control permissions to the C:\Temp folder
    • TEMP and TMP Environmental Variables are pointing to C:\Temp
    • AppWorx user is in the Administrators group

    Unfortunately we're still having the issue.  I'm trying a couple of other things but am having no luck so far


  • 4.  RE: DNA - PS_FILELOADER on Server 2016

    Posted 02-13-2020 02:36 PM
    ​You should be able to get the new version 1.0.0.2 of ps_fileloader now. This version should fix your problem with the ps_fileloader hanging on errors when running on windows 2016


  • 5.  RE: DNA - PS_FILELOADER on Server 2016
    Best Answer

    Posted 02-10-2020 01:23 PM
    ​The problem seems to be an issue with ps_fileloader calling sub SQTs when running Windows 2016. If the called SQT has a problem then the sqr7wt.exe that is called can produce a popup causing ps_fileloader to just hang.

    I am testing a new ps_fileloader now from the dev team that fixes this problem. Hopefully this new version should be released soon.