AppWorx, Dollar Universe and Sysload Community

Expand all | Collapse all

UniViewer Console webstart link not working

  • 1.  UniViewer Console webstart link not working

    Posted 10-19-2020 12:25 PM
    Hello,

    We have a couple of users who are trying to access our UVC console. Univiewer console webstart, http://<DNS name>/univiewer_console_webstart/, through all types of browsers, and are getting HTTP error 404, page not found error.  Is there someone who can assist and advise what they need to do?  So far, we have only 2 users who are having these issues.  I'm not sure what's causing their issue though, but mine is working, and most users.
    We have version UVC 6.9.21.

    Thanks in advance for your help.
    Gerry Muyargas


  • 2.  RE: UniViewer Console webstart link not working

    Broadcom Employee
    Posted 10-20-2020 04:51 AM
    Hello Gerry,
    most likely the traffic is closed to your Tomcat server from your colleagues' workstation.
    You can check that via:
    telnet dnsname 80

    Usually Tomcat is deployed on port 8080, are you sure your Tomcat connector is listening on port 80?

    They could simply install the Univiewer Console Standalone instead on their laptops as it behaves exactly as the Univiewer Webstart.

    Docu about the Webstart configuration on Tomcat:
    https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/dollar-universe/6-10/Univiewer_Administrating_8/Installing_UVC/UniViewer_Console_Web_Start_Installation.html

    Thanks
    Adrian




  • 3.  RE: UniViewer Console webstart link not working

    Posted 10-20-2020 09:27 AM
    Thanks Adrian.  We tried telnet, and seems to be able to connect, as it gave a blank screen after.
    We already have UVC standalone already installed, but we usually have our users connect via the browser so they can connect from any device.

    I actually had the same issue after I cleared my browser cache.  So, I thought of recycling Tomcat from the UVC server itself, and after that it worked for me and the user.  Thanks for your help!

    Regards,
    Gerry


  • 4.  RE: UniViewer Console webstart link not working

    Posted 10-20-2020 09:25 AM
    In addition to what @Adrian Fresno Menendez has stated, your organization should start looking into alternative solutions to WebStart as Oracle has deprecated this feature as of Java 11. Whether you use​ Oracle Java or an OpenJDK variant, this functionality will not be present going forward.

    The recommended path forward for Dollar Universe is to use UVC WebConsole. It offers similar benefits to WebStart in that the installation is centralized, therefore it only needs to be updated in one place. In addition to this, since all communication from UVC in this mode is done from the server hosting WebConsole, you will only need to set up your network for the one server, as opposed to every machine that might be running UVC locally (WebStart downloads a local version of UVC, which then has the exact same requirements as the standalone version). The only caveat to using WebConsole as opposed to WebStart is that all connected users would utilize the resources of the host server where WebConsole is running; you therefore need to size your host accordingly.

    ------------------------------
    Cordialement,
    Support Automation Apta
    ------------------------------



  • 5.  RE: UniViewer Console webstart link not working

    Posted 01-18-2021 01:39 PM
    I'd like to amend my previous statement. Both UVC WebConsole and UVC WebStart will not work with Java 11, as the underlying technology for both is Java WebStart (the JavaWS binary delivered until Java 8). So, the current recommendation is to continue using Java 8 if you would like to use WebStart OR WebConsole. Java 8, which includes WebStart, is supported until 2030.

    ------------------------------
    Regards,

    Domenico Cotugno
    Support Automation Apta
    ------------------------------



  • 6.  RE: UniViewer Console webstart link not working

    Posted 01-20-2021 11:55 AM
    Thanks for this info, I came here looking for similar info, although I'm also concerned about Java licensing, if I continue using Java 8 and whatever free updates they release, am I allowed to use that license for free? We don't use Java for anything outside of Dollar Universe.

    There is a lot of different vague info on this topic out there. Anything you could clarify would be great.

    Thanks,
    Ryan


  • 7.  RE: UniViewer Console webstart link not working

    Posted 01-20-2021 01:38 PM
    Edited by SupportAutomation AptaSolutions 01-20-2021 01:40 PM
    Hi Ryan,

    Though this likely merits its own topic, I can give you some hints.

    Though the Compatibility Matrix indicates otherwise, I've found that the OpenJDK 8 works just fine with Dollar Universe, and it has an open license (so I avoid any nebulous legal aspects of using Oracle). I use the AdoptOpenJDK version of Java 8 with the IcedTea-Web package (which can be selected during install) and it is functionally identical to Oracle Java. The Iced Tea-Web package is necessary to run any Web Start applications like UVC WebStart and UVC Web Console.

    There are a few minor changes you need to make for it to work with Dollar Universe, but they are one-time changes.

    Dollar Universe looks for the result of the 'java -version' command in order to ensure you are using a validated version of Java. With Oracle Java, the result is "java version" whereas with OpenJDK the result is "openjdk version". This will cause Dollar Universe components UVC and UVMS to fail both at install as well as during startup (if you replace Oracle Java with OpenJDK, for example). To work around this, here are the steps:

    When replacing Oracle Java with AdoptOpenJDK 8:

    For UVMS
    - Uninstall Oracle Java
    - Install AdoptOpenJDK 8
       - Make sure you manually select the options to: set the JAVA_HOME variable; set the javapath; install Iced Tea-Web
    - Modify your 'unienv' file to replace the JAVA_ORSYP path to the one pointing to the new AdoptOpenJDK installation path
    - Modify both the 'unistartms' and 'unistsrv' files to replace the string 'findstr /b "java version""' with 'findstr /b "openjdk version""'

    For UVC
    - In the 'univiewer_console' file replace the string 'findstr /b "java version""' with 'findstr /b "openjdk version""'

    I've tested this on Windows, but not yet on Linux, so it may be slightly different.

    If you need to install a new UVMS or UVC instance, there are other changes that need to be considered. If you respond here, I can give some additional guidance. I've also not tested with the Manager for Java or any other associated manager integrations. I can if need be and if you are using them.

    I hope this helps!

    ------------------------------
    Regards,

    Domenico Cotugno
    Support Automation Apta Solutions
    ------------------------------



  • 8.  RE: UniViewer Console webstart link not working

    Posted 01-30-2021 12:57 PM
    Hi,

    Interresting point there.
    I'm searching a way to considere java and console performance too.
    Does the AdoptOpenJDK respect the user agreement ?
    Did you test some performance checks result on your windows ?

    Thank you
    Eric

    ------------------------------
    Main director
    SynApps
    ------------------------------



  • 9.  RE: UniViewer Console webstart link not working

    Posted 14 days ago
    Hi Eric,

    I know that AdoptOpenJDK does not contravene any Oracle user agreements, if that's what you mean. On Broadcom's side, I expect no official support for this configuration as it is not in the compatibility matrix.
    As for performance, I've been running with AdoptOpenJDK since November on Standalone, WebStart, and WebConsole. I haven't noticed any performance degradation whatsoever, but I have not done any explicit benchmarking either. It should also be noted that my WebConsole instance is hosting a maximum of 2 users concurrently as I use it mainly for support testing purposes. That said, I do have customers that are using this configuration and the same sizing considerations need to be followed as per the official sizing guide.

    I also needed to make some tweaks to Tomcat, but I think that may have been related to the version I was installing at the time. See here for details:
    https://knowledge.broadcom.com/external/article/193089/uvc-webconsole-universeprotocol-decode.html

    I hope that helps!

    ------------------------------
    Regards,

    Domenico Cotugno
    Support Automation Apta Solutions
    ------------------------------