Automic Community

Expand all | Collapse all

Application manager 9.3.1

Jump to Best Answer
  • 1.  Application manager 9.3.1

    Posted 11-08-2019 03:54 PM
    Hi All,

    We have built the New Appworx environment with 9.3.1. version. While running the jobs in windows agent getting the file not found error  even though the file is in place.

    awexe RUNNING return 0
    disk_space=253689249792
    EXECS.BAT starting at Fri 11/08/2019 11:57:33.08
    'In EXECS'
    'calling'E:\Appworx\userlib\exec\ODI Launcher.bat
    DEBUG is False
    Error System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
    at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
    at System.Diagnostics.Process.Start()
    at ntspawn.Program.createChildProcess()
    at ntspawn.Program.Main(String[] args)
    end of E:\Appworx\exec\BODY2.BAT status 1 Fri 11/08/2019 11:57:34.18
    err is:'1'
    log_run is:'Y'


    I observed that  its not accepting the space in the  file name ODI Launcher.bat  on newer version 9.3.1 . The same job use to run in the older version Application manager 9.1.3.

    I tried to changed the bat file as ODI_Launcher.bat and the job got completed without any issues. But business dont want to change the file name since its used in many jobs.

    Have anyone encountered similar issue

    Any help/advise would be appreciated

    - Raja




  • 2.  RE: Application manager 9.3.1
    Best Answer

    Posted 11-13-2019 02:24 PM
    Hi Raja,
    The issue is with ntspawn. It was modified to fix "killing jobs on windows agents" but it now has issues with spaces in paths, etc.
    I copied a previous version of ntspawn and without any other changes jobs worked.

    I have a case open with support, but it would be good if others did the same to get things rolling.

    Scott


  • 3.  RE: Application manager 9.3.1

    Posted 11-14-2019 03:10 PM
    Hi Scott,

    Thank you so much. It works and i have tested the same. i have raised a case with Vendor too.

    -Raja

    ------------------------------
    Senior Consultant
    Capgemini
    ------------------------------