Automic Community

Expand all | Collapse all

MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

Jump to Best Answer
  • 1.  MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

    Posted 09-18-2019 10:17 AM
      |   view attached
    I have an issue about external dependencies in an Workflow.
    Inside the workflow are two external Jobs which have to start after workflowstart.
    I start the workflow, set both external jobs to ENDED_INACTIVE and get following error in the Job after the external jobs:
    U00011516 Cannot find status definition: 'ENDED_INACTIVE'.

    Also the field in the dependencies - which should contain the value ENDED_INACTIVE ist empty (with AWI).
    I reproduce this workflow in the old Java-Client, same Error, only the empty dependency field is correctly filled (it seems that this is an AWI-Display-Problem).

    I have attacht a picture of the Proces-Monitor where you can see it.




  • 2.  RE: MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

    Posted 09-19-2019 05:02 AM

    Futher test shows, that this behavior only exists, wenn I manualy set the external objects to inacitve, for normal runs it works.

    This can be nessesary, if the external Object starts to early and not after workflowstart, so that an manuel correction is nessecary (setting ext. Objekt to inaciv). Only in this case the error occure.
    I don't know if this behavior was already in previous version. 

    Our suggestion for our customer is to start the following Object with "Go Immediately"




  • 3.  RE: MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

    Posted 09-19-2019 05:04 AM
    Hi Hans-Juergen,
    have you seen this bug fix



    ------------------------------
    Thx & rgds
    Christian
    ------------------------------



  • 4.  RE: MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

    Posted 09-19-2019 07:17 AM
    Bingo, exactly the behavoir. Is therfore a hotfix for our 12.2.3 HF2 in planing (currently the latest Version for the 12.2.3 UI)?


  • 5.  RE: MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

    Posted 09-19-2019 07:49 AM
    I have open a case by Broadcom to provide a hotfix for our Version 12.2.3 HF2. Every new or modified Workflow with ext. Dependencies show this behavior if it ends INACTIV(E)


  • 6.  RE: MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

    Posted 09-24-2019 04:44 PM
    Edited by Pete Wirfs 09-24-2019 04:46 PM
    This has been fixed in "Automic.Web.Interface 12.3.0 HF2"
    Reference: WEBUI-11436

    ------------------------------
    Pete
    ------------------------------



  • 7.  RE: MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

    Posted 09-25-2019 02:27 AM

    We need a patch for 12.2.3, because upgrading to the next minor version is very costly (need 3-4 month). 

    It have to be fixed in the next servicepacks 12.2.4. Therfore we don't test so much, because servicepacks only eliminates bugs, no new feature.
    So I'am waiting for response from Broadcom-Support.




  • 8.  RE: MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'
    Best Answer

    Posted 09-25-2019 11:16 AM
    The available fix is to the Web.Interface only.  It may be OK to use the 12.3.0 HF2 Web.Interface against your 12.2.3 AE.

    ------------------------------
    Pete
    ------------------------------



  • 9.  RE: MessageU00011516 Cannot find status definition: 'ENDED_INACTIVE'

    Posted 09-26-2019 04:47 AM
    Do you have experience with this constellation of AE and AWI. I guess thats only possible within a minor version to mix versions.
    Have someone this constellation running?