Automic Community

Expand all | Collapse all

How to run Appworx 9.3.1 version with OpenJdk 11

Jump to Best Answer
  • 1.  How to run Appworx 9.3.1 version with OpenJdk 11

    Posted 02-19-2020 05:06 AM

    We have upgraded our Appworx Environment to 9.3.1 version and recently we upgraded Apache 2.4.41 (Unix).

    But we are facing issues with Openjdk11 which cause application down and once we downgraded the version to Openjdk8, we were able to restart the application.

    Please suggest how we can run our Appworx 9.3.1 version application with Openjdk11?

    Thanks in Advance..!!



  • 2.  RE: How to run Appworx 9.3.1 version with OpenJdk 11
    Best Answer

    Posted 02-20-2020 09:47 AM
      |   view attached
    Hi, We upgraded from V9.1.1 to V9.3.1, and are using Oracle Java 8. We found out if you use Java 1.8.0_201 or higher you need the user_keystore files.  This is for the master, and all remote agents. If you use Java 8 201 or higher on your PC it invokes the need for the keystore files even if your host is not there.

    I did see in the compatibility guides for V9.3.1 a reference to OpenJDK 11. There is a hint there gives a specific version. I have those downloaded. I did not try using OpenJDK on the host, but did on my PC. I changed the client.properties file to point to OpenJDK 11.1 I believe.  I think you might need the keystore files with OpenJDK too.
    It has something to do with the cyphers dropping anon, and NULL. I actually helped a user who upgraded the Java on there PC to get into our V9.1.1 system production which was not upgraded yet. I had them modify the java.security file to not exclude anon, and NULL.

    I am uploading the file for you that I found for compatibility.   If you cannot get this to work, open a case.

    Thank you,

    Rich