Automic Community

Expand all | Collapse all

Applications Manager 9.2.3

Jump to Best Answer
  • 1.  Applications Manager 9.2.3

    Posted 01-07-2020 10:48 AM
    Hello all,

    I'm preparing to upgrade my Applications Manager version 9.1 to version 9.2.3. I have three tiers (Development, Integration and Production) and will be upgrading starting with the Development tier. Does the vendor support  object import/export between these two versions? If so, has anyone experienced issues exporting objects from 9.1 into 9.2.3?  Any insights are greatly appreciated.

    Thank you,

    Jim

    ------------------------------
    Core Services Specialist
    University of New Mexico
    ------------------------------


  • 2.  RE: Applications Manager 9.2.3

    Posted 01-08-2020 09:30 AM

    Hi Jim,

     

    We upgraded from 9.1 to 9.3 and have been able to import/export objects between the two.  I know that isn't your exact situation.

     

    Laura






  • 3.  RE: Applications Manager 9.2.3
    Best Answer

    Posted 01-08-2020 10:09 AM
    Hi Jim, I was under the assumption when using the export/import feature the best practice was to be on the same release from and too.  I would think it would work, but caution is recommended. We just had someone at our site tell me they tried to export from prod at V9.1.1 into test at V9.3.1 and was given a warning.

    When we migrated from AIX to Linux we were on V9.1.1 on both platforms. I installed V9.1.1 on Linuix then we migrated the database over from say AWPROD to AMPROD. We ran the awinstall on Linux. But we also ran a series of bulk change scripts to change all kinds of paths, and environment variables.

    Upgrading now from Linux V9.1.1 to V9.3.1 was not so bad. A lot of changes with the new client, and user_keystore files we had to get working.

    We have a nice problem we found recently with our OAE success scripts. There is an issue where the SUCCESS.OAE script is not being called which then does not call the COMPLETION. If works 1 out of three times I was told. We are not sure what is going on, and I am working with support. Hopefully they can help us.

    The OAE component has changed from using DBMS pipes to Advanced Queuing, and this might have something to do with it.

    Hope it goes well for the upgrade on your side.    I am new to using the community, it looks very helpful.

    Thank you,

    Rich






  • 4.  RE: Applications Manager 9.2.3

    Posted 02-06-2020 12:17 PM
    Hi Rich,

    Going up to ver. 9.3.1, did you need to install user_keystore files on everyone's computer? My understanding is that SSL config is required with 9.3
    What about user's java versions? In my environment, users have java versions that are below 1.8. IF i'm reading documentation correctly, java 1.8 is the minimum level for users to run the AppWorx client.

    Thanks,
    Jim

    ------------------------------
    Core Services Specialist
    University of New Mexico
    ------------------------------



  • 5.  RE: Applications Manager 9.2.3

    Posted 02-06-2020 12:32 PM
    we're also working on moving to Open JDK. (64 bit  build 11.02+7-LTS)
    we had to put the keystore files everywhere. but that's easy enough I thought.

    as for java:
    I believe our problem is that some user's java versions are "too high" - I use 1.8.0_131
    in these cases, they double click the jar file and nothing happens
    we're still looking into this, but one of my colleagues posted that Java 8u211 and later versions do not seem to work for us

    we're running into a separate problem - using LDAP to login. I'll post separately, but wanted to ask here as well. Users cannot login - we are getting LDAP authentication error.

    ------------------------------
    Joe Simon
    Drexel University
    ------------------------------



  • 6.  RE: Applications Manager 9.2.3

    Posted 02-06-2020 02:31 PM

    Hi Joe,

     

    We upgraded to 9.3 and are using Open JDK 11 also and are also getting an error.   

     

    LDAP authentication error.  Anonymous bind failed.

     

    It's interesting to hear we're not the only ones.  We'd been on a lower version of Open JDK and were told updating to 11 was the solution.  Apparently that's not the case.

    Have you put in a ticket with Broadcom?






  • 7.  RE: Applications Manager 9.2.3

    Posted 02-06-2020 03:55 PM
    Hi everyone,  I could be off but be sure to check the compatibility papers  for AM 9.3.1.  I thought I saw information on OpenJDK 11 in a hint.
    Hint meaning there could be a specific level of OpenJDK 11 you need to be at.  OVer the years I have found Appworx, Applications Manager have specific versions that work better than others. I saw a lot of this on AIX, and now Linux. And I have seen the host issues, and PC client. If something is wrong on the client, you usually see some sort of socket error. Turn on debug in the environment file, and you see a lot more of the errors.

    Rich


  • 8.  RE: Applications Manager 9.2.3

    Posted 02-07-2020 11:30 AM

    Sorry to throw this out here, but with LDAP (once it's working of course) can you enable CAS or SAML Protocol or is it even supported ?

     

    Thanks






  • 9.  RE: Applications Manager 9.2.3

    Posted 02-11-2020 02:54 PM
    We do have an open ticket with support.

    Also, note we did try LDAP using our AD server, but we then receive the anonymous bind error. I am told our AD server will not allow anonymous binds. So we are looking to implement AD.

    Joe Simon
    Drexel University


  • 10.  RE: Applications Manager 9.2.3

    Posted 02-06-2020 03:50 PM
    Hi Jim, I learned with the migration from V9.1.1. When I do these upgrades I always pull all of the compatibility documents, and documentation guides. Since we run OAE, and Banner (Rapid Automation) I pull those too.  When I upgraded my first instance from V9.1,1 to V9.1.1 I first had some confusion over the client.properties, and connections.properties files. I found out that using the connections.properties file didn't let me use https, I had to use http and put the port in it.

    I then found out the hard way about the user_keystore files. Turns out you this all comes into play when you use a Java level of 1.8.0_201 or higher on the host, or PC client.  In 201 they added anon, and NULL to the chyper exclusions. When my host was 1.8.0_131, and PC 1.8.0_151 I did not need them. It is when I upgraded the host to 201 or higher. I also found out the hard way that even using 1.8.0_131 if I had 201 or higher on my PC I needed to have them. We even had one user upgrade there PC Java to a level 201+ and they got the socket error. My fix was to have them upgrade the java.security file on there PC, and remove the anon, and NULL values. This was on my V9.1.1 prod system which I wil lbe upgrading on 2/23.

    It took me a while to figure out the keystore. But now I got it working on my AMUPGD, and AMTEST systems.   I su to the user the master runs under, and I have the JAVA_HOME set to 1.8.0_231. I run through the commands to create the keystore in the data directoriy, and encrypt it.  Then I copy the files to my agents data directories.

    You will need to make sure you have the keystore files in the correct location on your PC. There is various documents that say .Appworx, or Appworx directory.
    The actual location that worked is.  My id is rblumlei.

    C:\Users\rblumlei\Appworx\<master>       For me master would be directories AMUPGD, or AMTEST, or AMPROD.

    IF you are running OAE you need to have your DBA run through the SQL scripts for the Advanced Queuing...

    I hope this information helps.. I learned a lot.     Buy the way I did install multiple levels of Oracle Java on my PC, and tested them all. I even installed OpenJDK
    11 which pay attention to the compatibility notes. It gives a hint to a specific levels ..

    Thank you,

    Rich