AppWorx, Dollar Universe and Sysload Community

Expand all | Collapse all

RAFTP ERROR

  • 1.  RAFTP ERROR

    Posted 05-04-2017 03:10 PM
    I tried to upload a file to the FTP site and keep connection error.   See log information below.  


    Details: Software caused connection abort: socket write error
    com.uc4.ftpjob.DataTransferException:  Software caused connection abort: socket write error.
        at com.uc4.ftpjob.commands.impl.CopyCommand.throwDataException(CopyCommand.java:707)
        at com.uc4.ftpjob.commands.impl.CopyCommand.execute(CopyCommand.java:642)
        at com.uc4.ftpjob.commands.impl.CopyCommand.execute(CopyCommand.java:446)
        at com.uc4.ftpjob.commands.CommandProcessor.execCommand(CommandProcessor.java:257)
        at com.uc4.ftpjob.commands.CommandProcessor.processCommands(CommandProcessor.java:162)
        at com.uc4.ftpjob.commands.CommandProcessor$processCommands.call(Unknown Source)
        at FtpJob.runJob(FtpAgent.groovy:304)
        at com.uc4.extensibility.types.CITAgent.dispatchJob(CITAgent.java:258)
        at com.appworx.agent.extensibleagent.A$_A$1.A(GenericExtensibleAgent.java:748)
        at com.appworx.automic.ra.extensibility.container.D.doRun(CITWorker.java:100)
        at com.uc4.be.threading.AbstractWorker.run(AbstractWorker.java:367)
        at java.lang.Thread.run(Unknown Source)
    Caused by: java.net.SocketException: Software caused connection abort: socket write error
        at java.net.SocketOutputStream.socketWrite0(Native Method)
        at java.net.SocketOutputStream.socketWrite(Unknown Source)
        at java.net.SocketOutputStream.write(Unknown Source)
        at com.jcraft.jsch.IO.put(IO.java:60)
        at com.jcraft.jsch.Session._write(Session.java:1368)
        at com.jcraft.jsch.Session.write(Session.java:1335)
        at com.jcraft.jsch.ChannelSftp.sendWRITE(ChannelSftp.java:2352)
        at com.jcraft.jsch.ChannelSftp.access$100(ChannelSftp.java:38)
        at com.jcraft.jsch.ChannelSftp$1.write(ChannelSftp.java:731)
        at com.uc4.ftpjob.commands.impl.CopyCommand.execute(CopyCommand.java:628)
        ... 10 more

    Command aborted with error message:  Software caused connection abort: socket write error. Software caused connection abort: socket write error.
    Job will continue to process commands.
    ******************************************* End of job log *******************************************




  • 2.  RAFTP ERROR

    Posted 05-11-2017 02:59 PM

    Applications Manager ships with a jsch-0.1.39.jar file by default. This is a third party utility(jcraft) that Applications Manager use for file transfers. Updating the jar file does resolves many connection type issues. Please try to update this file, by following the steps outlined below:

    Download the newer file at:

    http://www.jcraft.com/jsch/

    1. Scroll down to the Download section and download the jsch-0.1.54.jar.
    2. On the server where the RAFTP Agent is installed, backup the current jsch-0.1.39.jar file located in the $AW_HOME/web/classes directory to $AW_HOME(or another backup location)
    3. Place the new jsch-0.1.54.jar in the $AW_HOME/web/classes directory.
    4. Re-run the FTP job.
    Regards,
    Phearith




  • 3.  RAFTP ERROR

    Posted 05-22-2017 07:01 PM
    I am still getting the same error.   Any other suggestions?


  • 4.  RAFTP ERROR

    Posted 05-24-2017 02:10 PM
    Hi Brad,

    This file you are uploading to the "FTP site" out of curiosity, how big is the file.  Is this happening for all files uploaded to this "FTP Site" or just a few.  Also, which method are you doing?  FTP,  SFTP, FTPS, FTPES (and what port are you using for it?)


  • 5.  RAFTP ERROR

    Posted 05-31-2017 04:37 PM
    The file size I am uploading is about 200KB.  Any file I upload to this vendor fails.  I am receiving errors on any file I upload to the site.  I can download files without any issues.   I have tried several different SFTP clients with mixed results.  WINSCP failed,  Filezilla was successful and SFTP from Linux terminal was successful. 


  • 6.  RAFTP ERROR

    Posted 06-02-2017 08:10 PM
    That sound very strange, the fact that it work on Filezilla/Linux but not with WINSCP nor automic.

    What the exact version of this RA FTP?

    Can you give the full job output of when it failed?  And a screenshot of the value you tried via Linux SFTP.
    (Feel free to Private message me the screenshot or full job output if it contain data you prefer it not to be display publicly).

    I also see that your contracted through Fisrve, which I do recommend also informing them of this issue you are running into and the can take a closer look with you (and if they are not able to find the root of the issue, they will contact Automic Support on your behalf as part/per the contract).


  • 7.  RAFTP ERROR

    Posted 02-01-2018 08:58 AM
    Hi Brad,

    I am getting same error.Did you solve this problem?

    thanks