Automic Community

Expand all | Collapse all

[Résolu] process_create in error

Jump to Best Answer
  • 1.  [Résolu] process_create in error

    Posted 02-06-2014 11:41 AM
    Bonjour,

    Depuis quelques jours, je constate sur l'un de mes nœuds en Production, une multitude de job en statut "Erreur de soumission".

    Cela dit, je ne parviens pas à en trouver la cause.


    Voici le message que je trouve dans le universe.log du nœud en question :

    [quote]
    [size=1][i]| 2014-02-06 16:33:00 |ERROR|X|DQM|pid=5831572.1050488| u_dqm_sub_job                | dqm_ecriture_article_prm returns 6 [709237UNI_DIR_EXEC:u_batch S_AS_LOGMX:XS0000001480561079D000000001U000000999.2023938                                                                                          [/i]
    [i]| 2014-02-06 16:33:00 |ERROR|X|DQM|pid=5831572.1050488| owls_dqm_job_submit        | u_dqm_sub_job returns 6[/i]
    [i]| 2014-02-06 16:33:00 |ERROR|X|DQM|pid=5831572.1050488| process_fnc_obj             | process_create in error: 6[/i]
    [i]| 2014-02-06 16:33:00 |ERROR|X|DQM|pid=5831572.1050488| u_dqm_process_client_requ | Error handling job request: owls_dqm_handle_job returns 104[/i][/size]
    [/quote]

    Est-ce un message qui vous parle?

    Toute piste est bonne à prendre, alors je suis preneur de tout.

    Merci


  • 2.  [Résolu] process_create in error

    Posted 02-07-2014 05:36 PM
    Bonjour,

    Avez-vous tenter de faire une reorg a froid?
    Ce genre de problème est généralement résolu après une reorg a froid:

    sous le repertoire mgr:
    1. uxshutdown
    2- uxsetenv
    3- ux_vrf_rgz_rst
    4- uxstartup

    Cordialement,

    Kamile


  • 3.  [Résolu] process_create in error

    Posted 02-10-2014 03:59 AM
    @kna : Je viens de tester la procédure que vous m'avez indiquée.
    Je n'ai pas [color=#666666][font=helvetica, arial, sans-serif][background=rgb(251, 252, 252)]ux_vrf_rgz_rst... Je n'ai donc pas pu faire de reorg à froid. Que me conseillez-vous?[/background][/font][/color]


  • 4.  [Résolu] process_create in error

    Posted 02-11-2014 02:58 AM
    Bonjour,

    Je pense donc que vous avez Dollar Universe 6, n'est-ce pas ?

    Le script de reorg a froid a été renommé en version 6. Le script est: bin/unireorg

    Cordialement,


  • 5.  [Résolu] process_create in error

    Posted 02-11-2014 04:16 AM
    Bonjour,

    Merci Didier Hoarau
    En effet, je suis sur une version 6.1.21.

    Je viens donc de procéder à une reorg comme indiqué dans les différents commentaires.
    Malheureusement, mon problème n'est pas corrigé. Voici le message rencontré seulement 10 minutes après ma reorg :

    [quote]
    | 2014-02-11 09:40:01 |ERROR|X|DQM|pid=4400232.4365344| u_dqm_sub_job             | dqm_ecriture_article_prm returns 6 [749213UNI_DIR_EXEC:u_batch  S_AS_LOGMX:XS0000001290580448D000000001U000000960.2065450                                                               
    | 2014-02-11 09:40:01 |ERROR|X|DQM|pid=4400232.4365344| owls_dqm_job_submit       | u_dqm_sub_job returns 6
    | 2014-02-11 09:40:01 |ERROR|X|DQM|pid=4400232.4365344| process_fnc_obj           | process_create in error: 6
    | 2014-02-11 09:40:01 |ERROR|X|DQM|pid=4400232.4365344| u_dqm_process_client_requ | Error handling job request: owls_dqm_handle_job returns 104

    [/quote]

    Ce problème est vraiment récurrent... Je n'ai vraiment plus d'idée.
    Je ne serai pas contre de nouvelles pistes.


  • 6.  [Résolu] process_create in error

    Posted 02-13-2014 12:16 AM
    Bonjour,

    Si la réorg n'a pas fonctionné, il faut peut être essayer de faire une remise à zéro des fichiers de DQM.

    Pour faire une remise à zéro:
    - Arreter Dollar Universe
    - Renommer les fichier data/u_jobfile.dta, data/u_jobfile.idx, data/u_prmfile.dta et data/u_prmfile.idx
    - Démarrer Dollar Universe
    - Executer: uxresetque que=*

    Est-ce que ca résout le problème ?

    Cordialement,


  • 7.  [Résolu] process_create in error

    Posted 02-14-2014 03:21 AM
    @Didier : Merci beaucoup pour cette solution. Elle semble être concluante. je n'ai pas eu d'erreur de soumission depuis l'application de la solution.


  • 8.  [Résolu] process_create in error

    Posted 02-17-2014 01:05 AM
    Content de savoir que cela a résolu votre problème /smile.png' class='bbc_emoticon' alt=':)' />

    Merci pour votre retour.


  • 9.  RE: [Résolu] process_create in error
    Best Answer

    Posted 12-04-2019 10:32 AM
    Bonjour,
    En  V6.10.11  d'Univiewer,Dollaru et Reporter sur Linux 2.6.32-754.23.1.el6.x86_64
    à chaque démarrage de la collecte des logs par Reporter ce message apparaissait dans universe.log:
    | 2019-12-04 15:15:00 |ERROR|X|DQM|pid=4645.140609914402560| u_dqm_upd_numbers_que | u_dqm_sub_job: [ENTRY:104795] Nbexe=(-1) is negative for queue: SYS_BATCH

    J'avais tenté la réorg à froid sans succès avant de tombé sur ce tuto.
    Cette manip est venu à bout de l'erreur.

    Merci Didier