DX Infrastructure Manager

 Unable to connect UIM 20.3.3 on Win 2012R2 to SQL server 2017 on Win2019

Glenn Weavind's profile image
Glenn Weavind posted 11-16-2021 10:55 AM
Recently had a tedious experience trying to connect our existing UIM 20.3.3 installation to the same SQL server DB, but with the DB now hosted on Win2019 (previously on Win2012R2 cluster) NOT attempting to move to TLS 1.2 at this time (more fun with that later).
In summary: UIM worked to SQL 2014 hosted on Win2012R2 no problems, non-encrypted DB connection: copied DB to SQL server 2017 hosted on Win2019 - which *does* have SCHANNEL configured for TLS 1.2 only - and data_engine couldn't connect.  Packet capture showed the beginnings of an encryption exchange (TDS7 from UIM, response from SQL server, end of TDS7 from UIM and SQL side sends FIN) between SQL server and UIM and then the TCP connection was torn down.  Neither SQL server is configured for TLS 1.2 - but it may be that Win2019 overrides this?  Have another client connection to the same, newly built SQL server (also not using TLS 1.2), but this time hosted on Win2019 and this application works fine (obv different DB on SQL server).
Q: has anyone else seen this combination cause problems, please?
The other major SQL client app couldn't support TLS 1.2 until recently, which is why UIM wasn't moved to TLS 1.2 for the DB connection.

Thanks.
David Michel's profile image
Broadcom Employee David Michel
This might help:
data_engine will not start after changes in the environment
https://knowledge.broadcom.com/external/article?articleId=212756
Glenn Weavind's profile image
Glenn Weavind
Solved: it turned out to be easy.  We were still using the SQLOLEDB client, which, IIRC, is not supported in SQL2017 (and, from memory, there's been a brisk thread about this elsewhere in this community during June 2021).  Changing to use SQLNCLI11 fixed it.