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Tech Tip - CA Privileged Access Manager: Input Language not supported

By wonsa03 posted Sep 17, 2017 07:19 PM

  

CA Privileged Access Manager Tech Tip by Kelly Wong, Principal Support Engineer for 15th September 2017

Background

Every user account is associated with preferred Keyboard Layout:

By default, AUTO is used, indicating PAM will use the default keyboard configuration from the computer that user initiated the PAM session. 

 

Issue

The following warning message prompt is returned when user attempts to RDP from PAM:

Cause

The AUTO keyboard layout works fine as long as the default input language from the computer that user initiated the PAM session matches with any of the following options:

  • DA
  • DA-DK
  • DE
  • EN-GB
  • EN-US
  • ES
  • FI
  • FR
  • FR-BE
  • FR-CA
  • FR-CH
  • HU
  • IT
  • IW-IL
  • NO
  • PL
  • PT_BR
  • RU
  • SV
  • SV-SE

 

The warning prompt is returned since EN-AU has yet to be certified with PAM:

Workaround

Windows: Control Panel >> Change keyboards or other input methods - Set the default input language matching the closest supported keyboard layout option

 

OR

 

PAM: Users >> Manage Users - Set the keyboard layout for each PAM user

 

Logoff existing PAM session(s) running on the computer after the updates.

 

Going forward, the best approach is to raise an enhancement request/ idea to include new input language to the Keyboard Layout option in PAM.

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