Issue
Web Agent configuration wizard fails to detect all the OHS instances
Environment
Web Agent Version : r12.51 until CR8, r12.52SP1 until CR4
OS : Windows
Cause
This issue happens when the OHS instances are customized and installed outside of the default <ORACLE_HOME>\instances directory.
Here is how web agent currently determines the location of the instances.
- Read the path of the ORACLE_HOME by looking at all the keys under "HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE" registry.
- Then look for instances under <ORACLE_HOME>\instances folder ( for 11g release). (To identify correct ORACLE_HOME it also checks for couple of other files/folders)
e.g.
[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE]
"inst_loc"="C:\\Program Files\\Oracle\\Inventory"
[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OH582528179]
"ORACLE_HOME"="C:\\Middleware\\Oracle_WT1"
"ORACLE_HOME_NAME"="OH582528179"
"ORACLE_GROUP_NAME"="Oracle - OH582528179"
"NLS_LANG"="AMERICAN_AMERICA.WE8MSWIN1252"
"ORACLE_BUNDLE_NAME"="Enterprise"
"ORACLE_HOME_KEY"="SOFTWARE\\ORACLE\\KEY_OH582528179"
Now, this is all good if the OHS instances are installed using default installation. However, if the instances are customized and installed outside of this default location web agent configuration wizard fails to detect it.
Workaround
Additional Information