VMware NSX

 View Only
  • 1.  NSX-T manager "Out of memory"

    Posted Sep 30, 2021 02:17 AM

    I'm attempting to get a small NSX-T lab up and running.  I have the appliance version 3.1.2.0.0.17884005, and the VM keeps running out of memory:

    GBDickinson75_0-1632967899876.png

    If that's too small to read, the error is "Out of memory: Kill process [number] (java) score [number] or sacrifice child"

    I've run it under both Workstation 16 and ESXi 7, and get the same result.  I've gone from the smallest VM up to Medium and get the same issue.  I'm stumped, any ideas?



  • 2.  RE: NSX-T manager "Out of memory"

    Posted Oct 02, 2021 02:47 PM

    If anyone is interested, it seems that there is a memory leak in the version I was using.  I got a copy of the 3.1.3 OVA, and it's been running for 12 hours now without any issue.  I also noticed with the previous version that it was using 33+ GB of RAM (per the appliances page in the web interface), where the 3.1.3 version is using only 15 GB.  So...problem solved?  At least this one will run long enough for me to do basic configuration.