SYMPTOM:
While accessing a SSH device with Password Rotation Policies applied, by the moment the password should be changed CA PAM returns an error. The log shows the following messages:
SEVERE: UpdateTargetAccountCmd.invoke 15212: Failed to establish a communications channel to the remote host. (...)SEVERE: UpdateTargetAccountCmd.invoke 15220: A problem occurred while executing the script processor. Please try your request again or contact your Administrator. (...)Caused by: Sourced file: inline evaluation of: ``// *************************************************************************** / . . . '' : Method Invocation channel.readUntil : at Line: 345 : in file: inline evaluation of: ``// *************************************************************************** / . . . '' : channel .readUntil ( passwordEntryPrompt )
CAUSE:
The Target Application was originally created as type "Generic" and then changed to something else (for example, "Unix").
SOLUTION:
Delete the target application and create it again, using the correct type.