DX Operational Intelligence

Tech Tip: Updated Data Adapters for VMware vCenter v6.5 

08-01-2017 05:30 AM

CCC 2.9.4 has been certified to collect metrics from VMware vCenter v6.5 for DB adapters.

 

Deploy the attached data adapter files to collect metrics from vCenter v6.5. Follow these steps:

  1. Stop the Apache Tomcat service (CA_CCC).
  2. Navigate to CA\Capacity Command Center<version> \ApacheTomcat\webapps\DM\WEB-INF\classes.
  3. Make a backup copy of Hyp_Vmware_ESXi_Daily.xml and Hyp_Vmware_ESXi_Weekly.xml.
  4. Replace Hyp_Vmware_ESXi_Daily.xml and Hyp_Vmware_ESXi_Weekly.xml with the attached files.
  5. Start the Apache Tomcat service (CA_CCC).

 

With a vCenter v6.5 DB, the following warnings and error messages were observed when expected/correct data is not available or null in vCenter:

  • online_memory: Value for the column can not be determined.
  • total_memory: Value for the column can not be determined.

These warnings/errors do not impact the data.

 

Note: VMware removed some of the columns of the vpx_resource_pool table. We have therefore removed the resource_pool map, which was using the vpx_resource_pool table.

Statistics
0 Favorited
0 Views
2 Files
0 Shares
0 Downloads
Attachment(s)
zip file
Hyp_Vmware_ESXi_Daily.xml.zip   13K   1 version
Uploaded - 05-29-2019
zip file
Hyp_Vmware_ESXi_Weekly.xml.zip   13K   1 version
Uploaded - 05-29-2019

Tags and Keywords

Comments

11-16-2017 08:35 AM

Hi Tomáš,

Here is the answer provided by Dev:

The adapter will work only with SQL and Oracle DB.

Currently there is no option to pull the data from Postgres DB of vCenter.

Regards,

Clemens

11-16-2017 03:11 AM

Does this adapter support vPostgreSQL comming inevitably along vSphere 6.5?

08-17-2017 09:30 AM

Our engineers confirmed that the VMware data adapter is compatible with the VCenter 6.5 API.

08-15-2017 04:25 PM

Does this mean the VMWARE API data adapter is also compatible with VCenter 6.5 API?

 

Thanks,

 

David

08-03-2017 05:37 AM

I checked with the engineers team, and here is their reply:

Yes these DA are backward compatible. But it will not collect resource_pool metrics because it’s remove from the DA for vCenter 6.5.

08-01-2017 09:34 AM

Hi

 

During an upgrade from their current version to vCenter 6.5, it is likely that some sites will run a mix of versions of vCenter for an extended period.

 

With the understanding that ‘resource pool' metrics will no longer be collected, is this DA backwards compatible with vCenter 6.x, vCenter 5.x ?

 

Thanks

Related Entries and Links

No Related Resource entered.