In very rare circumstances, a nas table becomes corrupted or otherwise inaccessible.
This article discusses the steps needed to correct this scenario.
Article Contents:
Problem:
After an upgrade of UIM, we noticed several symptoms related to discovery server:
- discovery_server queue is empty
- (new) devices are not appearing in UMP
- (new) devices are not being inserted to the database
- see discovery_server complaining about 'NAS_CS_STATE_MONITOR' in the logs:
10 Oct 2016 13:58:46,383 [probeDiscovery-1] ERROR com.nimsoft.discovery.common.util.ExceptionUtil - Error importing device: org.springframework.jdbc.BadSqlGrammarException: PreparedStatementCallback; bad SQL grammar []; nested exception is com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name 'NAS_CS_STATE_MONITOR'.
Environment:
This issue was found after upgrading from UIM 8.2 --> UIM 8.42.
This information is generally applicable to most versions of UIM.
Cause:
This was found to be related to corrupted data being stored in the NAS tables that causes issue during the upgrade process.
Resolution:
DIRECT LINK TO ARTICLE
Additional Information:
This issue has only been seen in a few environments - it's very rare.
The steps above provide a permanent resolution.