DX Application Performance Management

Expand all | Collapse all

How to force Enterprise Manager and agents to discuss on IPv4 ?

Jump to Best Answer
  • 1.  How to force Enterprise Manager and agents to discuss on IPv4 ?

    Posted 12-13-2012 04:53 AM
    Hello,

    I would like to know how to force IPv4 on the EM and on the agents because actually we have this :

    java 2228268 wily 456u [color=#ff0000]IPv6 [color]0xf100060002cf0290 0t0 TCP [::1]:*->[::1]:55553
    java 2228268 wily 465u [color=#ff0000]IPv6 [color]0xf100060003737398 0t0 TCP xx.xx.xx.xx:8081 (LISTEN)
    java 2228268 wily 467u [color=#ff0000]IPv6 [color]0xf1000600033a5398 0t0 TCP xx.xx.xx.xx:5001 (LISTEN)
    java 2228268 wily 470u [color=#ff0000]IPv6 [color]0xf100060001321398 0t30755233 TCP xx.xx.xx.xx:5001->yy.yy.yy.yy:46937 (ESTABLISHED)
    java 2228268 wily 476u [color=#ff0000]IPv6 [color]0xf100060001163398 0t37638042 TCP xx.xx.xx.xx:5001->yy.yy.yy.yy:57236 (ESTABLISHED)
    java 2228268 wily 481u [color=#ff0000]IPv6 [color]0xf100060003535b98 0t14130144 TCP xx.xx.xx.xx:5001->yy.yy.yy.yy:24566 (ESTABLISHED)
    java 2228268 wily 482u [color=#ff0000]IPv6 [color]0xf100060002e7f398 0t47719392 TCP xx.xx.xx.xx:5001->yy.yy.yy.yy:24579 (ESTABLISHED)

    Is there a solution for this ?

    Thanks a lot for your help.

    Julien.


  • 2.  RE: How to force Enterprise Manager and agents to discuss on IPv4 ?
    Best Answer

    Posted 12-13-2012 01:25 PM
    Julien,

    What is the Operating System on which your EMs and agents are running, respecitvely? In Windows environments, you can configure the system to prefer IPv4.

    Additionally, in the [font=Courier New]IntroscopeEnterpriseManager.profile[font] of your EM configuration, setting the [font=Courier New]introscope.enterprisemanager.ipaddress[font] property to the IPv4 address of the EM host will make the EM only accept connections from agents or clients using IPv4, which might solve your problem. More information on this property is available in the APM Bookshelf.

    Finally, for your Java agents, you could also try adding the environment variable [font=Courier New]-Djava.net.preferIPv6Addresses=false[font] as one of the JVM's startup arguments.


  • 3.  RE: How to force Enterprise Manager and agents to discuss on IPv4 ?

    Posted 12-14-2012 05:07 AM
    Thanks for your answer,

    Our systems is Unix AIX.

    I have already tried to set the EM profile with the IPv4 address and i have also configured one of my JVM with the "preferIPv6Addresses" settings ... no joy.

    We have the setting "-Djava.net.preferIPv4Stack=true" on the agents. Theorically, it shoud go on IPv4.

    We do not feel a slow-down in the use of the EM, everything is fine. It is just weird to see those IPv6 connections ...