DX Application Performance Management

Expand all | Collapse all

Configuring IIS 7.0 to Publish Statistics

Jump to Best Answer
  • 1.  Configuring IIS 7.0 to Publish Statistics

    Posted 04-27-2012 01:16 PM
    I seem to have consistent problems configuring the Web Server Power Pack for IIS, and I'm sure it must be something simple that I'm missing. I'm fairly new to IIS, so please don't rule out what you perceive as obvious!

    I have the Power Pack installed on a central server and it is reporting performance metrics from IIS 6.0 just fine. This problem is IIS 7.0 specific.

    Here are the install steps I'm completing:
    - Install the power pack
    - Create wily directory under intepub/wwwroot
    - Edit VBScript.bat with appropriate paths/filenames
    - Run VBScript.bat to verify data is being produced.
    - Register VBScript.bat
    - Start VBScript service
    - Create virtual directory (called iisperfstats), and point to inetpub\wwwroot\wily, where my file is being created

    At this point, I can access the iisstats.html page just fine from the server itself, however I can't access it remotely.

    I have tried adding the page as the default document, but this did not help.
    I have verified read permissions for the directory.
    I have verified that anonymous authentication is enabled for the virtual directory
    I have verified that the authorization rules include allowing all users

    I think I must be missing something simple, so if anyone has an idea what that is, please let me know!

    Thanks!


  • 2.  RE: Configuring IIS 7.0 to Publish Statistics

    Posted 05-03-2012 04:48 PM
    Hello Community,

    Any thoughts for Frederik?

    Thanks!
    Mary


  • 3.  RE: Configuring IIS 7.0 to Publish Statistics

    Posted 05-14-2012 05:01 PM
    I'm actively working on this one with a client, so I'll let everyone know if I see this problem also.


  • 4.  RE: Configuring IIS 7.0 to Publish Statistics
    Best Answer

    Posted 09-20-2012 08:55 AM
    Was there any answer for this? We are seeing the following issue when we try and run VBScript.bat by hand:

    C:\Wily_IIS>VBScript.bat
    Publishing IIS performance statistics to C:\InetPub\wily\iis-stats.html every 15 seconds...
    C:\Wily_IIS\PublishIISStats.vbs(62, 2) (null): 0x80041010

    C:\Wily_IIS>