Layer7 Privileged Access Management

Expand all | Collapse all

Error "CA Privileged Access Manager Server Control system call is not loaded." in installation agent CA PAM SC in redhat (tested in 7.3 and 7.4)

  • 1.  Error "CA Privileged Access Manager Server Control system call is not loaded." in installation agent CA PAM SC in redhat (tested in 7.3 and 7.4)

    Posted 05-02-2019 09:23 AM

    Hi community

     

    After the installation of the agent in a redhat server the following error is generated when starting the agent with the command ./seload

     

    finalizing the installation process

     

     

    initializing the agent

     


    I have made several times the installation of the agent in redhat 7.3 and 7.4 and I always get the same error. To rule out an error in the installation procedure or in the installation medium, perform the installation on a suse 11 server with successful results.

     

    any idea about it



  • 2.  Re: Error "CA Privileged Access Manager Server Control system call is not loaded." in installation agent CA PAM SC in redhat (tested in 7.3 and 7.4)

    Posted 05-02-2019 12:06 PM

    Hello

    i guess this is compitability issue as for PAM SC 14.0 need the patch DE336225 to support RH 7.3 or 7.4 as the 14.0 GA support until RH 7.2 : 

    check this link : https://docops.ca.com/ca-privileged-access-manager-server-control/14-0/EN/support-compatibility-matrix-index#SupportCompatibilityMatrixIndex-ServerMatrix

    you can have this patch from here : https://docops.ca.com/ca-privileged-access-manager-server-control/14-0/EN/release-information/solutions-and-patches 

    you can find the ENTM iso and the third party iso link.

     

    or you can use the PAM SC 14.1 to install your ENTM server , also you will notice CA  replaced JBoss with wildfly in that release

     

    best regards



  • 3.  Re: Error "CA Privileged Access Manager Server Control system call is not loaded." in installation agent CA PAM SC in redhat (tested in 7.3 and 7.4)

    Posted 05-02-2019 04:45 PM

    Hi Abdel

     

    Thanks for your answer, the installation of the agent worked correctly. I have the following error when trying to access the EndPoint administration console.

     

    Connection failed Socket creation failed

     

     

     

    The installation is in the test enviroment and hostname is fictional. This error is present only in the EndPoint´s that are installing with fix PAMSC_DE344290-14.01.0.315-_LINUX_64. The endPoint´s that are install with the DVD8114758E_CA_PIM_14.0_Endpoint_Components_for_Unix run perfectly.

     

    Some idea for this ?



  • 4.  Re: Error "CA Privileged Access Manager Server Control system call is not loaded." in installation agent CA PAM SC in redhat (tested in 7.3 and 7.4)

    Posted 05-05-2019 07:21 AM

    Hello Juliano,

     

    „Socket creation failed" is indicating a TCP connectivity issue from the Endpoint Management to the seosd on the actual endpoint.

     

    Please make sure you have not blocked TCP 8891 in both directions between both boxes.

     

    See https://docops.ca.com/ca-privileged-access-manager-server-control/14-1/en/reference/used-ports/unix-endpoint-used-ports for further details on the used ports.

     

    Should the issue remain, please open a formal Support Ticket and we shall analyse it accordingly.

     

    Best Regards,

    Andreas