DX Infrastructure Manager

Expand all | Collapse all

Compatibility between robot and UIM

Jump to Best Answer
  • 1.  Compatibility between robot and UIM

    Posted 12-28-2018 01:09 PM

    Hello,

     

    We are trying to figure out if UIM 8.5.1 supports the new robot with version 7.9.7.

    According to the Compatibility Matrix (for UIM 8.5.1), only robot versions 7.80 and 7.9.1 are mentioned:

    https://support.nimsoft.com/downloads/doc/NMSCompatibility_SupportMatrix_current.pdf 

    [section Robot 7.80 and 7.91 Support Matrix]

     

    Although robot versions 7.93  and 7.9.7 are mentioned in the Compatibility Matrix for UIM 9.0, there is no reference regarding previous versions of UIM.

     

    Is it safe to install the newer robot versions?

    Is there any compatibility matrix for UIM/Robot relations?

     

    Thanks.



  • 2.  Re: Compatibility between robot and UIM
    Best Answer

    Posted 12-31-2018 11:10 AM

    Currently, there is no UIM/ ROBOT PSM.

    In the past clients have always been able to use newer robots with old version of UIM.

    Starting with the 7.9X version of robot and hub it has been recomended on the hub that the robot and hub probe version be the same.

    The robot machines reporting to the hub can be older versions or new versions without an issue.

    The UIM version really has to do with the CORE probe on the primary hub and the database scemea versions.

     

    as the robots do not talk directly to these probes in most cases and do not interact with the database, updating to newer robots on monitored machines has never been much of an issue.

     

    The new 7.95+ robots for the first time in many years is adding some new key functionality.

    this of course will not work without the newer version of UIM the activates these features namely MCS with enhanced profiles.

    But this will not prevent them from working on supported platforms with older versions of probes the way older robots worked.



  • 3.  Re: Compatibility between robot and UIM

    Posted 01-07-2019 12:55 AM

    Yes there is highly recommend to use the same version of hub and robots.

    However it is not mandatory. Older robot works with newer hub and vice versa.