DX Application Performance Management

Expand all | Collapse all

CA APM TEAM CENTER OPENING WITH A BLANK SCREEN

Jump to Best Answer
  • 1.  CA APM TEAM CENTER OPENING WITH A BLANK SCREEN

    Posted 10-12-2018 03:36 AM
      |   view attached

    Hi

     

    Team center is opening with a blank screen Webview is opening perfectly fine (APM 10.7)

     

    Also i checked the EM logs these lines i found there,

     

    DB version is 10.5.2.0, while your application has version 10.7. Denying to start ATC.

    DB is not available. Next attempt to retry to connect in 15 seconds.

     

    Also attaching the screenshot of error i get in team center.

     

    Regards

    Imran



  • 2.  Re: CA APM TEAM CENTER OPENING WITH A BLANK SCREEN
    Best Answer

    Posted 10-12-2018 09:32 AM

    @Imran_ali

    Team Center is showing blank screen because Database is  disconnected. Try to connect database again either start the database or provide right credentials in config/tess-db-config.xml file.



  • 3.  Re: CA APM TEAM CENTER OPENING WITH A BLANK SCREEN

    Posted 10-14-2018 07:47 PM

    Hi Imran Ali Khan,

    The EM log message you posted:

    "DB version is 10.5.2.0, while your application has version 10.7. Denying to start ATC.

    DB is not available. Next attempt to retry to connect in 15 seconds."

     

    It sounds like your EM was upgraded from 10.5.2 but you did not upgrade the APM DB version at the same time?

    Assuming this is Postgres if you can connect to the APM DB with pgadmin or command line psql you can check the version with this SQL:

    select ts_db_versions from ts_domains;

    If it does not show "10.7.0.0" then you need to run 10.7 EM Installer with "Database Only option"

    Upgrade the PostgreSQL Database - CA Application Performance Management - 10.7 - CA Technologies Documentation 

     

    Hope that helps

     

    Regards,

     

    Lynn