Service Virtualization

Expand all | Collapse all

Authentication failed for user [username=admin]

Jump to Best Answer
  • 1.  Authentication failed for user [username=admin]

    Posted 05-14-2018 12:39 PM

    I´m having authentication problem after moving DevTest to external databases. I have two external MySQL databases. One for Enterprise Dashboard and one for Registry. 

    The error in registry log is:

     

    2018-05-14 16:12:22,429Z (13:12) [ServerRequestResponder 2] ERROR com.itko.lisa.test.LisaSecurityManager - Authentication Error
    org.springframework.security.authentication.BadCredentialsException: Authentication failed for user [username=admin]
    at com.ca.dts.security.authentication.internal.NamedDelegatingAuthenticationProvider.doAuthentication(NamedDelegatingAuthenticationProvider.java:75)
    at com.ca.dts.security.authentication.AbstractDevTestAuthenticationProvider.authenticate(AbstractDevTestAuthenticationProvider.java:195)
    at org.springframework.security.authentication.ProviderManager.authenticate(ProviderManager.java:174)
    at com.itko.lisa.test.LisaSecurityManager.authenticate(LisaSecurityManager.java:754)
    at com.itko.lisa.test.LisaSecurityManager.authenticate(LisaSecurityManager.java:713)
    at com.itko.lisa.coordinator.TestRegistryImpl.authenticate(TestRegistryImpl.java:2279)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at com.itko.lisa.net.RemoteMethodExec.execute(RemoteMethodExec.java:57)
    at com.itko.lisa.net.ServerRequestHandler.processRMIMessage(ServerRequestHandler.java:533)
    at com.itko.lisa.net.ServerRequestHandler.access$600(ServerRequestHandler.java:70)
    at com.itko.lisa.net.ServerRequestHandler$5.run(ServerRequestHandler.java:451)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: org.springframework.security.authentication.BadCredentialsException: Bad credentials
    at org.springframework.security.authentication.dao.DaoAuthenticationProvider.additionalAuthenticationChecks(DaoAuthenticationProvider.java:99)
    at org.springframework.security.authentication.dao.AbstractUserDetailsAuthenticationProvider.authenticate(AbstractUserDetailsAuthenticationProvider.java:166)
    at com.ca.dts.security.authentication.internal.NamedDelegatingAuthenticationProvider.doAuthentication(NamedDelegatingAuthenticationProvider.java:70)
    ... 18 more
    2018-05-14 16:12:22,429Z (13:12) [ServerRequestResponder 2] WARN com.itko.lisa.net.RemoteMethodExec - InvocationTargetException on invoke authenticate
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at com.itko.lisa.net.RemoteMethodExec.execute(RemoteMethodExec.java:57)
    at com.itko.lisa.net.ServerRequestHandler.processRMIMessage(ServerRequestHandler.java:533)
    at com.itko.lisa.net.ServerRequestHandler.access$600(ServerRequestHandler.java:70)
    at com.itko.lisa.net.ServerRequestHandler$5.run(ServerRequestHandler.java:451)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: org.springframework.security.authentication.BadCredentialsException: Authentication failed for user [username=admin]
    at com.ca.dts.security.authentication.internal.NamedDelegatingAuthenticationProvider.doAuthentication(NamedDelegatingAuthenticationProvider.java:75)
    at com.ca.dts.security.authentication.AbstractDevTestAuthenticationProvider.authenticate(AbstractDevTestAuthenticationProvider.java:195)
    at org.springframework.security.authentication.ProviderManager.authenticate(ProviderManager.java:174)
    at com.itko.lisa.test.LisaSecurityManager.authenticate(LisaSecurityManager.java:754)
    at com.itko.lisa.test.LisaSecurityManager.authenticate(LisaSecurityManager.java:713)
    at com.itko.lisa.coordinator.TestRegistryImpl.authenticate(TestRegistryImpl.java:2279)
    ... 13 more
    Caused by: org.springframework.security.authentication.BadCredentialsException: Bad credentials
    at org.springframework.security.authentication.dao.DaoAuthenticationProvider.additionalAuthenticationChecks(DaoAuthenticationProvider.java:99)
    at org.springframework.security.authentication.dao.AbstractUserDetailsAuthenticationProvider.authenticate(AbstractUserDetailsAuthenticationProvider.java:166)
    at com.ca.dts.security.authentication.internal.NamedDelegatingAuthenticationProvider.doAuthentication(NamedDelegatingAuthenticationProvider.java:70)
    ... 18 more



  • 2.  Re: Authentication failed for user [username=admin]

    Posted 05-15-2018 09:39 AM

    What Database are you trying to connect?  It looks like you are using Bad credentials.   Can you share the connection strings? 



  • 3.  Re: Authentication failed for user [username=admin]

    Posted 05-15-2018 02:32 PM

    I´m trying to connect to MySQL 5.7 database, with admin login.

     

    Here are the connection strings:
    lisadb.pool.common.driverClass=com.mysql.cj.jdbc.Driver
    lisadb.pool.common.url=jdbc:mysql://10.8.4.229:3306/dbregistrysqt?verifyServerCertificate=false&useSSL=true

     

    DevTest do connect to the database. It creates tables and data inside, as we can see in the picture of "acl_users" table below.

     



  • 4.  Re: Authentication failed for user [username=admin]

    Posted 05-15-2018 03:11 PM

    From the screenshot, it looks like the character set may not be UTF-8.  Can you please follow the link below

    Tech Tips: MySQL Cookbook for DevTest 9.1.0 and Later 

    Verify Step 6: 

    mysql> show variables like 'char%';



  • 5.  Re: Authentication failed for user [username=admin]

    Posted 05-15-2018 03:27 PM

    I did create the schema like UTF-8. Here is the screenshot:

     

    I believe the password encryption, from the previous screenshot,  makes it don´t look like UTF-8.



  • 6.  Re: Authentication failed for user [username=admin]
    Best Answer

    Posted 05-15-2018 05:31 PM

    Do you still have the issue?  if so, please open a ticket with CA support. We can do a webex to look at this issue. 

     

     

    Thanks

     

    Shiney 



  • 7.  Re: Authentication failed for user [username=admin]

    Posted 05-18-2018 10:52 AM

    Yes, I do. I've opened a ticket with CA support here in Brazil. They're trying to find the problem. Can we do a webex? It would be great.

     

    Thank you.

     

    Fabrício



  • 8.  Re: Authentication failed for user [username=admin]

    Posted 11-06-2018 10:29 AM

    Hi Fabrício,

     

    Could you please help with your findings as i am also getting the same issue.

     

    Thanks in advance.

     

    Kind Regards,

    Vaibhav J