Layer7 Access Management

Auth/AZ Using CA SPS Returning Login Failed

  • 1.  Auth/AZ Using CA SPS Returning Login Failed

    Posted 04-22-2019 08:25 PM

    Team,

     

    We are trying to set up the Authentication and AZ Call using CA SPS, we followed this Link: https://docops.ca.com/ca-single-sign-on/12-52-sp1/en/configuring/ca-siteminder-sps-configuration/configuring-the-authentication-and-authorization-web-services/. We were able to setup everything, and when testing the URL, we are getting Login Failed. I am using: /authazws/AuthRestService/login/lbmpoc/affwebservices/redirectjsp/redirect.jsp as my end point, and sending:

    <loginRequest>
    <binaryCreds></binaryCreds>
    <password>User1(</password>
    <userName>User1</userName>
    <action>GET</action>      
    </loginRequest>

     

    I am getting :[04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProcessResponses][Calling SM_WAF_HTTP_PLUGIN->ProcessResponses.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][CSmHttpPlugin::ProcessResponses][Processing Authorization responses.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][CSmHttpPlugin::ProcessResponses][Removing HTTP cache request headers.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProcessResponses][SM_WAF_HTTP_PLUGIN->ProcessResponses returned SmSuccess.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProcessResponses][Calling SM_WAF_AG_PLUGIN->ProcessResponses.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProcessResponses][SM_WAF_AG_PLUGIN->ProcessResponses returned SmNoAction.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProcessRequest][AuthorizationManager returned SmYes, end new request.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProcessRequest][End new request.]
    [04/22/2019][20:07:58][26387][140128887912192][][ReportHealthData][Accumulating HealthMonitorCtxt.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProxyValve::invoke][ProxyValve.invoke() Setting HTTP status to 200 allowing this request to proceeed. Return Code from HLA = 4]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][Tomcat5serializedAgentData::setStatus()][Setting response status = 200]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProxyValve::invoke][The agent finished processing the request.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProxyValve::processRedirect][Cookieless Federation is disabled. Returning without any processing.]
    [04/22/2019][20:07:58][26387][140128887912192][1b4acf42-b2e128b3-ccd28f6e-a8351b0c-b1c1aed0-8d6][ProxyValve::invoke][Leaving the agent.]

     

    And the User is Authenticated and Authorized by the Policy Server,  but in the response in Soap UI I am getting:

     

    <loginResponse>
    <message>Authentication Failed</message>
    <resultCode>LOGIN_FAILED</resultCode>
    <authenticationResponses/>
    </loginResponse>

     

    Can some one please help me if this is expected, or what am I doing wrong?

     

    Thanks,

    Avi