Clarity Service Management

Expand all | Collapse all

Strange pop-up "ERROR: server has been restarted"

Jump to Best Answer
  • 1.  Strange pop-up "ERROR: server has been restarted"

    Posted 10-16-2018 04:05 PM

    Hey Community,

    CA Service Desk Manager 17.1

    Architecture: Advanced availability

    Number of application Servers : 2

     

    have two CA SDM application servers and configured the Network load-balance name called A10.

    when user tried to login to the CA SDM using the private N/W IP address or the Network domain name which is configured on A10 network load-balancer , a pop-up is thrown as below and re-directed to login page on click on OK button of pop-up. however, we could see the logs that login is successfully created.

     

     

    it is very annoying to users, Please let me know how to fix this issue.

     

    Thank you,

    Regards,



  • 2.  Re: Strange pop-up "ERROR: server has been restarted"

    Posted 10-16-2018 04:18 PM

    Venka, do the users bookmarked SDM url with session id? if yes, they will get this message and they would need to remove the bookmark and bookmark again with the right url without seesion id. Thanks _Chi 



  • 3.  Re: Strange pop-up "ERROR: server has been restarted"
    Best Answer

    Posted 10-16-2018 04:46 PM

    Make sure that you've enabled Session Persistence (sometimes called Sticky Sessions) on your load balancer. If a user is sent to server A and gets their session ID, but is later redirected to server B, that session ID won't be valid and the "server has been restarted" message will be displayed. Turning on Session Persistence ensures that a user will be sent back to the same server for a set period of time - they will "stick" to a single server until their session is over, ensuring that their SDM session ID stays valid and relevant.



  • 4.  Re: Strange pop-up "ERROR: server has been restarted"

    Posted 10-19-2018 08:31 AM

    CodeGeek 

    Did the information provided by Chi_Chen or Sean.Johnston help?

    If so, please mark one of the responses are correct so that this thread can be closed.



  • 5.  Re: Strange pop-up "ERROR: server has been restarted"

    Posted 10-23-2018 06:03 AM

    - as suggested Sean.Johnston , we have enabled the session persistence on load balancer, pop-up got disappeared. we have scheduled the site full testing, we will have further update in week time.

     

    Thank you,



  • 6.  Re: Strange pop-up "ERROR: server has been restarted"

    Posted 10-23-2018 11:12 AM

    Hey Venkat,

     

    As SDM sessions are not duplicated across the web engines / servers,  enabling session persistence is the only option here.

     

    _R



  • 7.  Re: Strange pop-up "ERROR: server has been restarted"

    Posted 10-22-2018 10:46 AM

    This may be related to webengine crash like we are experiencing in our environnment.

     

    We do not have a load-balancer but we have a primary/secondary configuration.

     

    GuillaumeM and remy.jobin may share additionnal informations as they are working on this issue.

     

    Raghu.Rudraraju is working with them.



  • 8.  Re: Strange pop-up "ERROR: server has been restarted"

    Posted 10-23-2018 08:38 AM

    hi 

    there is the detail of my case.

     

    is is 17.1 Prod, Prim/sec setup. No LB. Web Director + multiple webengines involved. SSO is setup via NTLM.

    Problem:

    On the primary server we can track this error:

    09/10 13:54:27.11 sdm-app1-prod spelsrvr 7192 ERROR pcexec.c 6510 Spell interp failed at iss::cancel_tasks (...) issue.spl:4068: Math argument type mismatch

    09/10 13:56:53.89 sdm-app1-prod pdm_d_mgr 11416 ERROR daemon_obj.c 1990 Daemon _web_eng_sdm_app2_prod2 died: restarting

    09/10 13:56:53.89 sdm-app1-prod pdm_d_mgr 11416 SIGNIFICANT mgr_slump_if.c 1221 Starting: $NX_ROOT/bin/webengine -q -d domsrvr:12 -S web:sdm-app2-prod:2 -c $NX_ROOT/bopcfg/www/sdm-app2-prod-web2.cfg -r rpc_srvr:sdm-app2-prod

    09/10 13:56:59.00 sdm-app1-prod pdm_d_mgr 11416 SIGNIFICANT daemon_obj.c 3222 _web_eng_sdm_app2_prod2 : Process connected to slump but the agent missed it. Probably because the agent was being cycled. Monitoring is being transferred to the Manager

    and on the secondery server in the event viewer at the same time:

    application Error event 1000 Faulting application name: webengine.exe, version: 17.1.0.178, time stamp: 0x5af99814 Faulting module name: webengine.exe, version: 17.1.0.178, time stamp: 0x5af99814 Exception code: 0xc0000005 Fault offset: 0x001e3574 Faulting process id: 0x3c0 Faulting application start time: 0x01d448e5b91814de Faulting application path: D:\CA\SERVIC~1\bin\webengine.exe Faulting module path: D:\CA\SERVIC~1\bin\webengine.exe Report Id: 7f733748-0b99-4d0b-8f6f-131a6669ef3c Faulting package full name: Faulting package-relative application ID:

    Correct error message:

    09/17 09:39:24.41 sdm-app2-prod web:sdm-app2-prod 6036 ERROR encrypt.cpp 520 etpki_lib_init return -1

    09/17 09:39:24.41 sdm-app2-prod web:sdm-app2-prod 6036 ERROR encrypt.cpp 139 unable to initialise encryption operation 09/17 09:39:24.41 sdm-app2-prod web:sdm-app2-prod 6036 ERROR encrypt.cpp 139 unable to initialise encryption operation 09/17 09:39:24.41 sdm-app2-prod web:sdm-app2-prod 6036 ERROR encrypt.cpp 260 unable to initialise encryption operation 09/17 09:39:25.65 sdm-app2-prod domsrvr:11 5192 SIGNIFICANT connmgr.c 2410 Disconnecting client web:sdm-app2-prod:1 09/17 09:39:25.65 sdm-app2-prod web-director 5144 SIGNIFICANT webdirector.c 976 Removed the process - web:sdm-app2-prod:1

     

    If you have the same error this is the same case...