Clarity PPM

Expand all | Collapse all

HTTP Status 500 - Description http.500

  • 1.  HTTP Status 500 - Description http.500

    Posted 10-11-2018 04:11 PM

    Hello, 

     

    I have a problem after install the upgrade from 14.4 to 15.5
    The installation finish successfully but when I try to access to the application appear the followinr error:

     

    When I open the CSA in the field status version is incomplete and in the database state appear the message Needs update.

     

    When I select the Package application link appear a new button that says "Create Pachage".

     

    It download the niku.ear but I don't know how to install this and if this the solution.

     

    In the app_ca.log appear the following error:

     

    ERROR 2018-10-11 10:20:24,125 [localhost-startStop-1] niku.union (none:none:none:none) Clarity 15.4.1.115 failed to initialize.
    com.niku.union.config.ConfigurationException: The application failed to start because of a database configuration problem. Please review the application log for specific error information.
    at com.niku.union.config.ConfigurationManager.initAppServerType(ConfigurationManager.java:4097)
    at com.niku.union.config.ConfigurationManager.initAppServerIntern(ConfigurationManager.java:4030)
    at com.niku.union.config.ConfigurationManager.initAppServer(ConfigurationManager.java:4009)
    at com.niku.union.web.WebControlServlet.init(WebControlServlet.java:154)
    at javax.servlet.GenericServlet.init(GenericServlet.java:158)
    at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1144)
    at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1091)
    at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:983)
    at org.apache.catalina.core.StandardContext.loadup(StandardContext.java:4978)
    at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5290)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
    at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1421)
    at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1411)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:748)

     

     

    If anyone can help me I would be very grateful.

     

    Best regards.

    Patricio.



  • 2.  Re: HTTP Status 500 - Description http.500

    Posted 10-12-2018 01:14 PM

    It looks like your database version is for the 15.4.1 product and your installation code / files are 15.5, so there's a disconnect there.

     

    You should review your install/upgrade log to see how it failed to get all the way to 15.5 successfully.  You will not get a reason from the runtime application logs like app-system and app-ca why this is happening.

     

    You can also disregard the niku.ear package and deployment; this is for non-Tomcat application servers like WebSphere.



  • 3.  Re: HTTP Status 500 - Description http.500

    Posted 10-12-2018 01:45 PM

    That reminds me of the standard situation when the install script has successfully completed and you open CSA for the first time.

    If the database setting is unavailable I should expect to see just that.

    When it made available by setting the connection details right on the db tab you should see the Update button or something similar.

    If you do not get that then in the worst case the upgrade has failed and you have to roll back (as there is no force or resume in the install). Check the logs as the wizard suggests to see if the install was a success or a failure.



  • 4.  Re: HTTP Status 500 - Description http.500

    Posted 10-12-2018 02:52 PM

    Thanks Urmas, 

     

    I think that the solution is go back to the snapshot and start again the upgrade.

    Best regards.
    Patricio.