Service Virtualization

Expand all | Collapse all

How to Subscribe an IBM MQ Topic

  • 1.  How to Subscribe an IBM MQ Topic

    Posted 02-07-2019 05:00 AM

    Hi, We need to create an SV which should listen to an MQ Topic and Respond to a Queue. I have checked the "IBM MQ Native Send Receive Step" but i don't see it has an option to provide a Topic. In the previous versions of DevTest "IBM WebSphere MQ" step we have an option to Subscribe a topic. 

     

    DevTest Version is 10.3 and IBM MQ version is 8.0.0.1

     

    Could someone please help on this.

     

    Kevin.Bowman



  • 2.  Re: How to Subscribe an IBM MQ Topic

    Posted 02-07-2019 11:00 AM

    The Topics are under  IBM MQ JMS

    JMS Client Assets - DevTest Solutions - 10.4 - CA Technologies Documentation 

     

    Please create the JMS Topic  Assets and then try to publish to a Topic

     

    Thanks

     

    Shiney 



  • 3.  Re: How to Subscribe an IBM MQ Topic

    Posted 02-11-2019 05:20 AM

    Thanks Shiney for the repy. I tried the following ways to connect to the topic.

     

    1. In order to connect to the queue manager in which the "Topic" is lying we need to pass "UserName", So i enabled the Pro mode in "JMS Send Receive step" and could see there's an option "Client Id" in the Connection section, i passed the "UserName" and when tried connecting to the topic we are getting "Security Authentication error".

    • I asked MQ team to check why Queue Manager is not accepting the connection, he replied saying that the connection is using "My Windows Login Id" to connect to the Queue Manager. So the JMS Send Receive Step is ignoring the "Client Id" which we passed in the step

    2. I created a Virtual Service and deployed the Service to Portal which is installed in my local machine. 

    • In this case JMS Listen step is failing with same "Security Authentication error".  When MQ team checked the Queue Manager logs they could see that JMS Listen step is ignoring the "Client Id" which we passed in the step and it is using my system IP Address appended by CLNTSVR to connect to Queue Manager

     

    Could you please help us in resolving the issue as we need to start building the Virtual Service.