Layer7 Access Management

Expand all | Collapse all

Unable to install 12.8SP2 AdminUI

Jump to Best Answer
  • 1.  Unable to install 12.8SP2 AdminUI

    Posted 02-12-2019 11:02 AM

    Hello,

     

    When trying to install new 12.8SP2 adminUI get the following error when lauching the installer wint LAX_DEBUG=1

     

    ===============================================================================
    Please Wait
    -----------
    ***********Tags replace command Executed***********
    "/opt/application/CA/siteminder/adminui/runtime/bin/java" -classpath "/opt/application/CA/623910.tmp/*" com.netegrity.wamui.RemoveIMManagementConsoleEntries /opt/application/CA/siteminder/adminui/

    ***********Password Tool output***********
    STDOUT =
    STDERROR = java.net.UnknownHostException: java.sun.com
    at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.net.Socket.connect(Socket.java:589)
    at java.net.Socket.connect(Socket.java:538)
    at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
    at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
    at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
    at sun.net.www.http.HttpClient.<init>(HttpClient.java:242)
    at sun.net.www.http.HttpClient.New(HttpClient.java:339)
    at sun.net.www.http.HttpClient.New(HttpClient.java:357)
    at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1220)
    at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1156)
    at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1050)
    at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:984)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1564)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1492)
    at org.apache.xerces.impl.XMLEntityManager.setupCurrentEntity(Unknown Source)
    at org.apache.xerces.impl.XMLEntityManager.startEntity(Unknown Source)
    at org.apache.xerces.impl.XMLEntityManager.startDTDEntity(Unknown Source)
    at org.apache.xerces.impl.XMLDTDScannerImpl.setInputSource(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentScannerImpl$DTDDispatcher.dispatch(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
    at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
    at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
    at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
    at javax.xml.parsers.DocumentBuilder.parse(DocumentBuilder.java:177)
    at com.netegrity.wamui.RemoveIMManagementConsoleEntries.getDocument(Unknown Source)
    at com.netegrity.wamui.RemoveIMManagementConsoleEntries.main(Unknown Source)

    EXITCODE = 0

     

    ===============================================================================
    Please Wait
    -----------

     

    ===============================================================================
    Install Complete
    ----------------

    CA Single Sign-On Administrative Console is complete, but some errors occurred
    during the install.

    Please choose "Done", then see the installation log in
    /opt/application/CA/siteminder/adminui/install_config_info for details.

     

     

    Any idea if there is a known issue with this release ? 

    I'm not able to start the adminUI properly.

     

    Thank you,

    Julien.



  • 2.  Re: Unable to install 12.8SP2 AdminUI
    Best Answer

    Posted 02-12-2019 11:57 AM

    Have you performed the steps outlined in this section, this is specific to 12.8.02 release. 

     

    Look at the Troubleshooting section: 12.8.02 Administrative UI Deployment Fails

    https://docops.ca.com/ca-single-sign-on/12-8/en/troubleshooting/administrative-ui-troubleshooting 



  • 3.  Re: Unable to install 12.8SP2 AdminUI

    Posted 02-13-2019 04:27 AM

    Thank you very much for your inputs. Works fine I comment the outlined XML deployment files.

    Hope it will be fixed in next CR.

     

    Regards,

    Julien.



  • 4.  Re: Unable to install 12.8SP2 AdminUI

    Posted 02-15-2019 04:13 PM

    An updated AdminUI 12.8 Sp2 has been uploaded to the Support Site.

     

    https://support.ca.com/us/download-center/solution-detail.html?docid=659746&os=ANY&aparno=SS07352&actionID=5

     

    It resolves issue with the Admin UI not starting after deployment due to the jboss-deployment-structure.xml and application.xml files not being updated during the deployment process as expected.