Automic Workload Automation

Expand all | Collapse all

Does anyone use srvquery=1 in ucsrv.ini ?

  • 1.  Does anyone use srvquery=1 in ucsrv.ini ?

    Posted 04-15-2019 04:38 AM

    Hi all,

     

    does anyone use this setting? I do not dare changing this setting without further tests -but in my sandbox there are only 5 Agents available :-S

     

    srvquery=1

     

    [CPMsgTypes]

    ; srvquery: Determines which process responds to the agent's life sign message

    ; This setting has a performance impact. If the CP layer responds than the workload is distributed as agents are connected to different CP's whereas only one Primary WP exists in a system. Furthermore there is no need to hand over the agent's life sign messages to the PWP via the message queue tables which safes database IO's

     

    ; 0 - The primary work process (PWP) responds to the agent's live sign messages. (Slower)

    ; 1 - The communication processes (CPs) respond to the agent's live sign messages. (Faster)

     

    Any experiences and thoughts appreciated.

     

    THX

    Wolfgang



  • 2.  Re: Does anyone use srvquery=1 in ucsrv.ini ?

    Posted 04-15-2019 09:35 AM

    Hi Wolfgang,

    Yes, we use #srvquery = 1.
    In addition, I think what I wrote in the article “What is "Keep Alive" and how does it work?” about this setting is still true.

     

    However, the information in article “Tips and Tricks to Automation Engine Best Practices” is not accurate (like the documentatoin  ):

    “…This setting will cause the keepalive sent to the agent to be done by the CPs rather than the WPs…”

    Even this setting is used the keep alive (EXQUERY) is still sent by the PWP. Only the SRVQUERY (sent by the Agent) is answered by the CP and not by the PWP. This can be very, very helpful when the Engine (PWP) is overloaded.

     

    You should be also aware of the side effect described here in article “Agent Last Check column not populated”

     

    Cheers,
    Josef



  • 3.  Re: Does anyone use srvquery=1 in ucsrv.ini ?

    Posted 04-17-2019 04:11 AM

    Hi Tscho and Thierry,

     

    many THX for your info, will immeditaley read it & learn by heart :-)  !

     

    cheers, Wolfgang



  • 4.  Re: Does anyone use srvquery=1 in ucsrv.ini ?

    Posted 04-15-2019 09:35 AM

    Hi Wolfgang,

     

    One reason that could decide against changing it to '1' is that the 'Last Checked' column in the agent list is not populated anymore if you set it to '1'.

    You can find mor information about this behaviour in https://comm.support.ca.com/kb/agent-last-check-column-not-populated/kb000085077

     

    Best regards,

    Thierry



  • 5.  Re: Does anyone use srvquery=1 in ucsrv.ini ?

    Posted 04-23-2019 05:18 AM

    Hi Wolfgang,

    just a short statement: We also use srvquery=1 since years in our environments.

    Kind regards

    Tim