Clarity Service Management

Expand all | Collapse all

CA SC Form - lookup filter doesn't work

  • 1.  CA SC Form - lookup filter doesn't work

    Posted 03-13-2019 11:00 AM

    Hi friends,

    I'm quite stuck - could anyone help me with Catalog Data Object filtered with Dropdown Data Object?

     

    I have a lookup field on the catalog form which displays SDM categories. I would like to add the dropdown filter with the first level of the category tree (simply the string to the first '.').

     

    What I've done:

    1. Dropdown Data Object which displays the first level of the category tree. Works fine.

     

    2. New variable for the filter dropdown

     

    3. Data Object for the lookup field which is filtered by the variable. The values are never loaded

     

     

    Thank you for your suggestions,

    Jakub



  • 2.  Re: CA SC Form - lookup filter doesn't work

    Posted 03-14-2019 01:12 AM

    Hi Jakob,

     

    Here are a few tips.

    1. Reverse the order of your columns. Service catalog expects the first column to be the id and second to be the label in select/dual list fields.

    2. Not sure why you’re using concat. Please try this in the where clause. 

     

    sym like ‘%%y_cat_l1% + ‘%’

     

    With this clause the variable will be input and a wildcard will be at the beginning and then another wildcard appended on the end. Please also replace the single quotes, on my phone I don’t have the option to disable smart quotes.

     

     

    edit: I just realized your using the drop down type in the variable. I’ve never used those so my second suggestion might not work but you should still fix the column order.  



  • 3.  Re: CA SC Form - lookup filter doesn't work

    Posted 03-14-2019 03:06 AM

    Good Morning Jakub.

    Perhaps the following query will show per your request:

    select distinct persid,sym as ctg_l1 from prob_ctg where del = 0 and ss_sym not like '%.%'

    Kind regards, Louis.



  • 4.  Re: CA SC Form - lookup filter doesn't work

    Posted 03-14-2019 04:19 AM

    Louis_van_Amelsfort, gbruneau, thanks a lot for your time and suggestions.

     

    I've found that everything works fine locally on the SC server.. 

     

     

    Any ideas what should be wrong? We use a proxy server for accessing the SC from the Internet and I have a VPN - it doesn't work in both cases (VPN and Internet). On the other hand, we don't face any other issues regarding Data Object, Lookups, Dropdowns etc... Everything else works fine.

     

    EDIT: the behavior is the same in Report Builder, Catalog Form and USS Catalog Widget.

     

    Thank you,

    Jakub



  • 5.  Re: CA SC Form - lookup filter doesn't work

    Posted 03-14-2019 09:35 AM

    Good Afternoon Jakub.

     

    My earlier proposal on the query text (select distinct persid,sym as ctg_l1 from prob_ctg where del = 0 and ss_sym not like '%.%') appeared to work for you, right?

    That's why I did that 'mark as correct'.

     

    Please open another thread (or possibly, better a standard case?) for the 'other' issue you described.

     

    This to keep each and every 'issue' you want to be worked on, as clear and as clean as possible.

    And thus avoiding any confusion for every one, joining this community thread.

     

    Thanks in advance for your understanding and kind regards, Louis.



  • 6.  Re: CA SC Form - lookup filter doesn't work

    Posted 03-14-2019 05:55 PM

    Dear Louis,

    the goal for the query itself was to return distinct values of the first category level (the string till the first '.'). The original query is OK, your query returns something else...

     

    The problem I described was about loading the dropdown filter and it is not related to any of the two queries, but to something else (possibly some configuration issue or network troubles).

     

    I will raise the support case for this problem.

     

    Thank you,

    Jakub



  • 7.  Re: CA SC Form - lookup filter doesn't work

    Posted 03-15-2019 02:50 AM

    Good Morning Jakub.

     

    Sorry for mis=interpreting your question:

    "I have a lookup field on the catalog form which displays SDM categories. I would like to add the dropdown filter with the first level of the category tree (simply the string to the first '.')."

     

    For me, it was meant to ask for the query text. Again, my apology for this.

     

    Thanks in advance for your understanding and kind regards, Louis.