Layer7 API Management

Expand all | Collapse all

Error creating application on portal 3.5

Jump to Best Answer
  • 1.  Error creating application on portal 3.5

    Posted 10-01-2018 10:08 AM

    Hi,

     

    I'm facing a problem with the Developer Portal 3.5, the customer is trying to create a new application, already checked the enroll with gateway and APIs created.

     

    When the customer try to create new application, he passes about all the process, selecting the API, etc... but when he tries to save the new application the portal replies a alert message: "The action could no be completed due to failure on the Gateway. Please contact your gateway administrator"  [attached "error_application.jpg"]

     

    After see the log file [attached "error_log.jpg"], noticed that received an null pointer exception on java .

     

    What can this be?

     

     

    Attachment(s)

    zip
    error_log.txt.zip   5K 1 version


  • 2.  Re: Error creating application on portal 3.5

    Posted 10-02-2018 04:54 PM

    Hello. I will note that you already have an open support case on this with Declan, so I would not want to take you in any different directions here, because it'd be possibly interfering with your support case. I was assisting Declan though the other day on this and I would encourage including the SSG logs too, as the error seems to indicate an issue with the Gateway rather than the Portal, supposedly.

     

    I just checked the support case and see the SSG logs attached to it now, so it will be reviewed soon and we will continue to work from there. 

     

    We should work from the support case for now though (at least from a CA Support perspective, if anyone else wants to chime in though please feel free), and we can circle back to this thread later to report back the resolution from the support case. This is just to keep consistency and prevent interference with the support case. I'm sure you can imagine that if advice from the community takes you in a different direction than the support case, then we can not possibly stay synced up and it will inevitably lengthen the time to resolution.

     

    EDIT: The support case open with CA Support for this topic is filed as CA#01204358. We need to follow-up on this support case periodically to ensure it's resolution is posted back to this community post.



  • 3.  Re: Error creating application on portal 3.5
    Best Answer

    Posted 10-29-2018 11:11 AM

    The final solution for this one from the support case :

     

    Customer had run localise site but had localistionSupported set to no.

    There are 2 content items that needed to be unlocalised (/sitebuilder/content/groups/Metadata/ApplicationPlatforms.xml and /sitebuilder/content/groups/APIPlans/sandbox.xml).

    /admin?action=unlocalise-document&path=/sitebuilder/content/groups/Metadata/ApplicationPlatforms.xml and /admin?action=unlocalise-document&path=/sitebuilder/content/groups/APIPlans/sandbox.xml corrected the problem.

     

    Regards

     

    Dirk