Automic Workload Automation

Expand all | Collapse all

Opening a version management object

Jump to Best Answer
  • 1.  Opening a version management object

    Posted 09-10-2018 10:18 AM

    I am trying to open an object that is in version management so I can see what I changed last week.  I am getting the error "Error during XRequest com.uc4.webui.communication.requestes.OpenObjectAdapter".   The only way I can see what I changed is to restore it and I am guessing that is not the way this is supposed to work.  I am running on version 12..1 and this is in the AWI.  Thanks for your help.



  • 2.  Re: Opening a version management object

    Posted 09-11-2018 03:34 AM

    Hi JeffMuller608908

     

    Which release of the AWI / Automation Engine are you using exactly ? It's 12.1, but is it 12.1.0, 12.1.1, 12.1.2, ... ? Does this happen with all objects, or just some ? I would try using the latest release and report an incident to support if it still persists.

     

    Best regards,

    Antoine



  • 3.  Re: Opening a version management object

    Posted 09-11-2018 10:06 AM

    It is 12.1.  It seems to be just this job.  It is a linux job, I can open other unix jobs and peoplesoft jobs but just not this particular linux one.  Thanks  Jeff



  • 4.  Re: Opening a version management object
    Best Answer

    Posted 09-12-2018 03:46 AM

    Hi Jeff,

     

     

    Once again, which version of 12.1 do you use ? There are several versions and service packs. If you are not running the latest release I would suggest to have a look at the Release Notes located here.

     

    After a quick search I came across this :

     

    Older object versions cannot be opened in the AWI Version Management (WEBUI-9220)

    1040527
    A problem has been fixed where trying to open old versions of objects in the Version Management page in the AWI resulted in an error with the following message: "Error during XRequest com.uc4.webui.communication.requests.OpenObjectAdapter." The same objects could be opened using the deprecated Java UI.

    Components:
    • UI
    Fix
    FiFixed versions:

    • Automic.Web.Interface 12.2.0
    • Automic.Web.Interface 12.1.3

     

    Please update your AWI to v12.1.3 - no need to update other components. If the issue still persists then please get in touch with support.

     

    Best regards,

    Antoine



  • 5.  Re: Opening a version management object

    Posted 09-12-2018 08:23 AM
      |   view attached

    I’m sorry, in too much of a hurry.  12.1.0  We just upgrade so we will probably not move up to the latest release yet.

     

    Jeff



  • 6.  Re: Opening a version management object

    Posted 09-12-2018 08:34 AM

    Thanks for your answer. The workaround in this case is to open the object from the Java UI. It is deprecated but can be handy from time to time  

     

    Best regards,

    Antoine



  • 7.  Re: Opening a version management object

    Posted 09-12-2018 08:41 AM
      |   view attached

    Ok, I will do that.  Thanks for your help.

     

    Jeff



  • 8.  Re: Opening a version management object

    Posted 09-12-2018 08:44 AM

    You are welcome