Layer7 Access Management

Expand all | Collapse all

CA SSO R12.8 Admin UI

  • 1.  CA SSO R12.8 Admin UI

    Posted 09-25-2018 08:37 AM

    Hi,

     

    After installing CA SSO Admin UI R12.8 on Linux server, we're trying to start the application server using standalone.sh. The server starts ok, but the logs keep on coming on Linux console and it never returns to bash prompt. If we try to close the console logs, it turns off the Admin UI. Do we need to do any configuration changes over here? I couldn't spot anything in CA documentation.



  • 2.  Re: CA SSO R12.8 Admin UI

    Posted 09-25-2018 09:13 AM

    Hi,

     

    How are you running the standalone.sh? From a script or manually from prompt?  If you are running it from the prompt, then it is up to how you launch it depending on the session you have opened. For example, if I access through a SSH client and I run it as is (i.e. ./standalone.sh) then it will behave as you described. If you wish to run it in the background etc, you need to launch accordingly to your OS, for example: # standalone.sh &

     

    This depends on your Linux OS, and you can refer to the OS documentation on how to run it on the background.

     

    If you are using a script to run it, it should be checked to see why it behaves this way.

     

    I hope it helps.



  • 3.  Re: CA SSO R12.8 Admin UI

    Posted 09-25-2018 02:19 PM

    Nothing wrong with manually starting the WAMUI while development and testing are in progress.  I suspect you'll eventually want to have the WAMUI start automatically upon system reboot.  When you're ready for that, you may want to visit SSO systemctl service files .



  • 4.  Re: CA SSO R12.8 Admin UI

    Posted 09-25-2018 02:51 PM

    There are many ways to do this on Linux, as seen in the comments above, depending on your preference.

    We also have documented auto start/stop scripts here:

    Auto Start Up And Stop Script for WAM UI - CA Knowledge 

     

    Or a pair of script here that allow you to return back to your shell after starting.

    wamui restart script with arguments 

     

    Hope this helps!



  • 5.  Re: CA SSO R12.8 Admin UI

    Posted 09-26-2018 08:08 AM

    Thanks all for your inputs !

     

    It's working fine now in background using systemctl files