Layer 7 Identity Management

Expand all | Collapse all

Identity Portal - Forgotten Password - verification screen blank

  • 1.  Identity Portal - Forgotten Password - verification screen blank

    Posted 06-07-2018 11:50 AM

    Product: CA Identity Suite 14.1 Virtual Appliance

    Component: CA Identity Portal 

    Feature: Forgotten Password (/sigma/public/index#/forgot-password)

    Issue: the identity validation screen (second step, aka verification screen) is blank/empty and no error in log files on both Identity Portal and Identity Manager sides

     

    first screen (Identification)

    second screen (Verification)

     

    If I perform the same test of the feature using CA Identity Manager environment UI (/iam/im/pubidentityEnv/ui7/index.jsp?task.tag=forgottenpassword), it works as expected:

     

    The related Admin Task is configured correctly on Identity Manager side and enabled as Web Service:

     

    Also configured correctly on Identity Portal side:

     

     

    What do I miss?

     

    Thanks and regards,

    Gabriele.



  • 2.  Re: Identity Portal - Forgotten Password - verification screen blank

    Posted 06-08-2018 10:06 AM

    This is likely some sort of configuration issue as I have seen another customer not have this problem. I would suggest opening a support case so that your configuration could be reviewed and so you can be assisted further.



  • 3.  Re: Identity Portal - Forgotten Password - verification screen blank

    Posted 06-10-2018 07:25 AM

    The portal supports only a wizard type forms, so you will need to clear the field: Prompt for secondary verification screen in the screen: Configure Forgotten Password Search Screen, AND clear the screen: Profile Screen for Secondary Verify. This will cancel the secondary verification screens

    And copy the screen: Forgotten Password Verify to a new one and edit it to include the security questions:

     

    Thanks to reuel01



  • 4.  Re: Identity Portal - Forgotten Password - verification screen blank

    Posted 06-11-2018 10:29 AM

    Hi Gil,

    I cleared the Secondary Verification Screen section.

     

    About the but If I configure |Question 1| + |Answer 1| instead of |VerifyQuestion| + |VerifyAnswer|, the task stops to work also on IM side with this error:

    2018-06-11 15:15:01,102 ERROR [ims.tasktrack.custom] (default task-4) There is no question available for step 0

    So I left the original configuration with  |VerifyQuestion| + |VerifyAnswer|:

     

    Anyway, the issue on IP side is still there.

    My only concern is about IP side what I have to do to make a right configuration:

    • do I have to create a Task object that points to IM Admin Task? Already done.
    • do I have to create a Form object? Already done.
    • do I have to create a Module Action and/or Profile and/or something else? Not done.

     

    Thanks and regards,

    Gabriele



  • 5.  Re: Identity Portal - Forgotten Password - verification screen blank

    Posted 06-11-2018 10:49 AM

    I interesting thing is, if I try to perform the same test through the IP Portal Admin console (/sigma/admin/), it works?!

     

    /sigma/admin/

     

    Public icon:

     

    Link: "Forgotten Password"

     

     

    Step 1: Identitication

    Step 2. Verification

    Final Step: reset Password

    Note: If I run directly the URL /sigma/public/index#/forgot-password it is shown in English language also if the browser is in Italian (User Id, Back, Next)

     

    but if I browse through Admin Console > Branding > Public > Forgotten Password, it is correctly shown in Italian language (ID utente, Indietro, Avanti):

    as configured