DX Infrastructure Manager

Expand all | Collapse all

GA Announcement: CA UIM 9.0.2

Sam Green11-08-2018 12:25 PM

  • 1.  GA Announcement: CA UIM 9.0.2

    Posted 10-31-2018 11:12 AM

    On behalf of CA Technologies, we appreciate your business and the opportunity to provide you with high-quality, innovative software and services. As part of our ongoing commitment to customer success, we regularly release updated versions of our products. Today, we are pleased to announce that CA Unified Infrastructure Management 9.0.2 is now available and according to Forrester consulting (study commissioned by CA) The Total Economic Impact™ of CA Unified Infrastructure Management is 321% ROI with a payback of < 6 months.

     

    New features for CA Unified Infrastructure Management 9.0.2 include:

    • Centralized management of alarm configurations at device, group levels with out-of-box best practice monitoring policies. Provides advanced options for defining static as well as dynamic thresholds, time over threshold and alarm message customizations along with conditional disablement.
    • Configure granular access privileges on a per user basis, within the realm of a single tenant i.e. sub tenancy.
    • Monitoring extensibility via usage of REST Api(s) with zero programming knowledge. RESTmon provides intuitive   wizard for mapping responses to metrices and Auto generates MCS templates.
    • Webhook based integration can trigger actions on any Automation platform (e.g. CA Automic) for self-healing     capabilities, against certain alarms.
    • Comprehensive integration with CA AIOps platform by continual feeding of meaningful data about the infrastructure, spanning from Hybrid cloud to mainframe. It enables automatic clustering of relevant alerts and suppress noise    through algorithmic insight, for faster time-to-repair and time-to-resolution.
    • Operator Console built using HTML5 UI with smarter User Experience workflows, richer set of out-of-box dashboards and ad-hoc reporting capabilities.
    • Hardened security compliance with TLS 1.2 encryption enablement for Database layer and 30+ Infrastructure     probes.
    • Upgraded Technology Stack, for 3rd party libraries e.g. VC++, OpenSSL, MySQL, MariaDB …etc.
    • Comprehensive inclusion of defect fixes till date, along with 50+ improvements for speed & reliability.


    We have included a Product Brief that details the features and highlights of this release. We also encourage you to visit the CA Unified Infrastructure Management product information page at https://www.ca.com/us/products/ca-unified-infrastructure-management.html.
    Download your copy of CA Unified Infrastructure Management 9.0.2 online at https://support.ca.com/. To install, upgrade follow the prescriptive procedures at DocOps.ca.com. If you have any questions or require assistance, contact CA Customer Care online at http://www.ca.com/us/customer-care.aspx.


    Should you need any assistance in understanding these new features, or implementing this latest release, our CA Services experts can help. For more information about CA Services and how you can leverage our expertise, please visit www.ca.com/services. To connect, learn, and share with other customers, join and participate in CA Unified Infrastructure Management CA Community at https://communities.ca.com/.


    For a list of Education courses recommended by role, please visit the CA Learning Paths and select the desired product. We update courses based on functional impact as well as high-demand; therefore, courses created from previous releases may apply to the current release.


    To review CA Support lifecycle policies, please review the CA Support Policy and Terms located at: https://support.ca.com/.


    Thank you again for your business.

     

    UIM Product Management

    dutsu06

    kiran_diwakar

    sensu04

    aggas01

    nelbe03

    RajeevKurupati

    SandeepTiwary

    ghosu04



  • 2.  Re: GA Announcement: CA UIM 9.0.2

    Posted 10-31-2018 04:22 PM

    Finally! Thank you.

     

    Question is this going to be posted on the old support site which was much much easier to understand what your downloading? Old site had one section called Downloads and there was an easy understanding of what you are downloading. (http://support.nimsoft.com/Default.aspx?center=portal/downloads )

     

    On the new site there are 6 UIM Download Categories, each with about 6-9 things in each with the same repeating names for the .isos.  HUH???  Where is just the Windows Installer for the base uim manager?



  • 3.  Re: GA Announcement: CA UIM 9.0.2

    Posted 10-31-2018 04:40 PM

    DanielBlanco, You are my Hero. 

     

    I had the exact same question/concern but your picture puts what I was trying to write to shame. Thank you.

     

    While we're at it, the deprecated OS list will cause some users, like me, a significant amount of consternation - note that support is being dropped for some probes/hub/robot on OS versions that are still active and supported by their suppliers. The real world of IT is full of systems that you'd like to upgrade/dispose of because of the age of the OS but just can't. To have CA dropping support for OS versions that are still supported by the vendor is a really bad sign.

     

    That and if you compare the probe support matrix to the release notes there is a significant amount of disagreement as to what is actually supported/possible to run and what's not. 

     

    Really have to hope that the documentation defects aren't indicative of the code quality. Though in all honesty, if the past is any measure, it will be. Besides this is an "even" version release which means, historically speaking, you should wait until 9.1.....

     

    -Garin



  • 4.  Re: GA Announcement: CA UIM 9.0.2

    Posted 10-31-2018 05:04 PM

    Reading the upgrade instructions they direct one specifically to http://support.nimsoft.com/Default.aspx?center=portal/Downloads  where the 9.0.2 packages definately do not exist.... Yet.

     

    Left hand putting the packages out for distribution group doesn't know what the right hand documentation writers are doing it appears.

    From: Upgrade UIM Server - CA Unified Infrastructure Management - 9.0.2 - CA Technologies Documentation 

     

    Download the UIM Server Install Package
    Follow these steps:

    Log on to the primary hub server as administrator.
    Log in to support.nimsoft.com and go to Downloads.

    Note: A CA support login is required.

    Download the following installation packages for your operating system:
    The UIM Installer (setupCAUIMServer executable)

    The UIM Server Packages (uimserverpackages zip file)

    Important! Both files are required on the system that hosts the UIM server. If the uimserverpackages zip file is not present, the installation fails.



  • 5.  Re: GA Announcement: CA UIM 9.0.2

    Posted 10-31-2018 06:38 PM

    Trying out the upgrade. Looks like the data_engine upgrade for MSSQL exhibits some failures:

     

    Oct 31 17:33:30:007 [1864] 0 de: ExecuteNoRecords - Query: exec spn_bas_SetVersion 'initialize', 'NIS_QOS_DATA',9.0200,5;
    go
    begin
    update qos_data
    set checksum = CONVERT(VARCHAR(41),HashBytes('SHA1', convert(varchar(1024),
    CONCAT(qos_data.qos,'#',qos_data.source,'#',qos_data.target,'#',qos_data.origin))),2)
    FROM S_QOS_DATA qos_data
    INNER JOIN S_QOS_DATA T on qos_data.table_id = T.table_id
    and T.checksum!=CONVERT(VARCHAR(41),HashBytes('SHA1', convert(varchar(1024),
    CONCAT(qos_data.qos,'#',qos_data.source,'#',qos_data.target,'#',qos_data.origin))),2);
    end;
    exec spn_bas_SetVersion 'finalize', 'NIS_QOS_DATA', null, 5;
    Oct 31 17:33:30:007 [1864] 0 de: [main] ExecuteNoRecords - 2 errors
    Oct 31 17:33:30:007 [1864] 0 de: (1) ExecuteNoRecords [Microsoft OLE DB Provider for SQL Server] Incorrect syntax near 'go'.
    Oct 31 17:33:30:007 [1864] 0 de: (2) ExecuteNoRecords [Microsoft OLE DB Provider for SQL Server] 'CONCAT' is not a recognized built-in function name.
    Oct 31 17:33:30:007 [1864] 0 de: COM Error [0x80040e14] IDispatch error #3092 - [Microsoft OLE DB Provider for SQL Server] Incorrect syntax near 'go'.

    Unsure the impact.



  • 6.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 11:37 AM

    If it matters, my database is SQL Server 2008R2 SP2

     

    It's probably not right but if you run:

     

    exec spn_bas_SetVersion 'initialize', 'NIS_QOS_DATA',9.0200,5; 
     
    update qos_data 
    set checksum = CONVERT(VARCHAR(41),HashBytes('SHA1', convert(varchar(1024), 
    (qos_data.qos+'#'+qos_data.source+'#'+qos_data.target+'#'+qos_data.origin)))) 
    FROM S_QOS_DATA qos_data 
    INNER JOIN S_QOS_DATA T on qos_data.table_id = T.table_id 
    and T.checksum!=CONVERT(VARCHAR(41),HashBytes('SHA1', convert(varchar(1024), 
    (qos_data.qos+'#'+qos_data.source+'#'+qos_data.target+'#'+qos_data.origin)))); 
     
    exec spn_bas_SetVersion 'finalize', 'NIS_QOS_DATA', null, 5; 

     

    You get past the nas and data_engine failing to start when this step in the upgrade fails.



  • 7.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 11:29 PM

    Yes Garin, The DB version SQL Server 2008 R2 SP2, is the root cause of the challenge. We will be providing a Hotfix for this latest by tomorrow. chumu01 , kodse02



  • 8.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-02-2018 02:16 PM

    Hello Garin, A hotfix (data_engine-9.02HF1.zip) has been released for this problem. The details are mentioned in the KB Article - UIM 9.0.2 data_engine errors for MSSQL 2008 R2 dat - CA Knowledge 



  • 9.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-02-2018 03:26 PM

    I have applied the fix and can confirm that the error no longer appears. I did force the tbnVersion table back to their 8.51 values so that the update would be triggered. 



  • 10.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 07:06 AM

    You wil need:

    - DVD500000000001956.iso CA UNIFIED INFRASTRUCTURE MANAGEMENT R9.0.2 LINUX INSTALLER INCLUDES UMP AND UNIFIED REPORTER
    - DVD500000000001957.iso: CA UNIFIED INFRASTRUCTURE MANAGEMENT R9.0.2 ROBOT INSTALLER
    - DVD500000000001958.iso: CA UNIFIED INFRASTRUCTURE MANAGEMENT R9.0.2- WINDOWS INSTALLER INCLUDES UMP AND UNIFIED REPORTER

    If you mount/unzip the iso files you will find the installation files that are referenced in the documentation



  • 11.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 10:26 AM

    Hi DanielBlanco and Garin,

     

    You can now access the UIM/UMP/UR/Robot installers from support.nimsoft.com in addition to being available on support.ca.com. The latest probe packages meanwhile are still available only on support.nimsoft.com.

     

    -Sandeep



  • 12.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 10:26 AM

    Okay I'm very glad its finally on the old support site. Its much easier to get what I need now from that page. 

    Look how simple it should be:

     

     

    Whoever created that UIM Download section on the support.ca.com really needs to fix that. Ask anyone to navigate and actually find the base UIM Windows Installer and not go crazy. Look at that mess. Why are there GEN##### and DVD##### of the same thing listed? 6 Categories and then possible 9 different download options..  



  • 13.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 10:49 AM

    Cheers DanielBlanco,

     

    Yup in its present form Download Management on CA Support isn't as intuitive as it should be. We will share this feedback with our Support Team.

     

    -Sandeep



  • 14.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 10:37 AM

    Hello
    Greetings to all!
    I have a doubt in the requirements to update the version of 8.5.1 to 9.0.2 is based on the database I have operating.
    The database I use is MYSQL 5.6, checking the previous requirements I see nothing that has points to consider for SQL and ORACLE database.
    Can I complete the update with the current database or do I have to migrate it to ORACLE or SQL?
    Greetings.



  • 15.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 10:52 AM

    Hi ddjl,

     

    Please review the Component Support Matrix on DocOps. We do support MySQL 5.6 in UIM 9.0.2.

     

     

    -Sandeep



  • 16.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 11:01 AM

    Hello -Sandeep

    Thanks for the information and prompt attention.

    Regards!



  • 17.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 11:33 AM

    It looks like the audit probe was left out of the list of probes that the installer upgrades automatically. The install process disables the probe at the start like all the others and tries to enable it at the end but it is left at version 1.22. Unfortunately 1.22 does not work with 9.0.2 and so errors out eventually. 

     

    The 9.02 version is in the archive already so it's a simple matter of applying the upgrade manually to it to correct but this should have been handled by the installer.

     

    -Garin 



  • 18.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 11:41 AM

    The next upgrade issue is....

     

    service_host seems not to understand the connection string returned by the new data_engine probe:

     

    Nov 01 07:51:07:984 [main, service_host] Request to probe "/dom/chub01/chub01/data_engine" callback get_connection_string was successful.
    Nov 01 07:51:07:986 [main, service_host] sh stop...
    Nov 01 07:51:07:986 [main, service_host] connectionManager shutdown...
    Nov 01 07:51:07:987 [main, service_host] sh stopped
    Nov 01 07:51:07:987 [main, service_host] unhandled Exception
    Nov 01 07:51:07:988 [main, service_host] java.lang.IllegalArgumentException: Data Engine connection string fails to contain database provider.
    at com.nimsoft.service_host.ServiceHost.getDbInfo(ServiceHost.java:918)
    Nov 01 07:51:07:988 [main, service_host] Exiting

     

    The other probes that need the database connection string seem to retrieve it successfully. And if one issues the callback manually a connection string i returned granted it is encrypted so it's hard to tell if it is actually missing the database provider or not.

     

    Anyone else run into this and have a workaround or fix?

     

    -Garin



  • 19.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 11:45 AM

    servcic_host was deprecated in place of wasp for ac2 and was not updated to allow the new connection method.



  • 20.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 12:06 PM

    Makes sense.

     

    It would be good then if the installer didn't try to restart it after disabling it and list it as an error that it failed to start at the end of the upgrade process. Creates some confusion. I'd actually suggest that the installer remove it.

     

    And the release notes on page 9 refers to installing or upgrading service_host which should probably be removed. Granted on page 56 there's an item titled "wasp Contains a Non-functional Key for Servicehost Address" that mentions the functionality of service_host moving. One would think that if a probe was being removed, it would rate it's own entry in the release notes.



  • 21.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-02-2018 02:12 AM

    Hi Garin, looks like service_host was deprecated in 851/851SP1. We've removed the reference in page 9 of the Release Notes.

    -Sandeep



  • 22.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 01:57 PM

    Looks like the changes in the way the database connection string is passed breaks the ability of the legacy IM tool to display alarms:

     

     

    Still investigating if this is a configuration issue from the upgrade but would love it if someone else who has upgraded a system could confirm or contradict.

     

    -Garin



  • 23.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 02:00 PM

    I would try just unistalling IM and reinstalling. That will usually fix an OCX error such as that.

    I do not recall seeing that error during testing and upgrading.



  • 24.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 03:02 PM

    I seem to remember this issue when I was beta testing 9.x. I had to uninstall IM and re-install for the Alarms to work again. There was also a KB on it already:

    Attempt to open Alarm List (alarm sub-console view - CA Knowledge 



  • 25.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-01-2018 04:12 PM

    Uninstall successful, reboot, install fails, uninstall fails, reboot, install fails, uninstall successful, reboot, install fails, uninstall successful, install successful. 

     

    Crazy but it's working again. Thank you.



  • 26.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-07-2018 06:17 AM

    I've just found the new probe download page, man that needs redesigning! It's awful to browse through

     

    It just needs to be an easy read, a simple list like before is absolutely perfect!



  • 27.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-07-2018 10:36 AM

    Whats the new probe download page URL?



  • 28.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-07-2018 10:58 AM


  • 29.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-07-2018 10:59 AM

    The "Release notes" still redirect you to the support.nimsoft.com site



  • 30.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-07-2018 12:52 PM

    Hi Greenones,

     

    Please use the Nimsoft Support Internet Archive - http://support.nimsoft.com/Default.aspx?center=felles/archive as that is where we still upload the latest probes.

    Regarding the usability of the new probe download page, as mentioned earlier in the thread, I've shared the feedback with the appropriate team. Meanwhile, please use Nimsoft Support as mentioned in the documentation.

     

    -Sandeep



  • 31.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-08-2018 12:25 PM

    After the first failure, I retried!1st attemptAnyone else had similiar issues?



  • 32.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-08-2018 12:29 PM

    Following the above failures I continued and the EMS probe is causing issues when trying to upgrade the WASP:

     



  • 33.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-08-2018 12:35 PM

    Yes, looks very familiar.

     

    Thankfully it appears though that the upgrade doesn't care about the current state of things. Particularly how much of 9.0.2 got installed. (Unlike the LifeRay upgrade from a couple versions ago - ugh)

     

    I had to run the upgrade (from 8.51) three times to get it to run to completion. And even then, it left a couple probes deactivated and untouched as far as updating. Easy enough to fix manually.

     

    So, run the upgrade, get the error. 

    Exit the upgrade per the dialog boxes.

    If UIM is stopped, start it. Use IM/AdminConsole (though aminconsole is probably broken at this point) to activate/start any deactivated probes.

    Repeat.



  • 34.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-08-2018 12:42 PM

    Thanks Garin,

     

    Yes, that's what I've tried to do

     

    EMS doesn't appear to be having any of it though..  I've deactivated and started, no good - deleted and redeployed - still reaching "max restarts".  I've done that several times

     

    Like you say though, it strangely seems happy! Even though it crashed half way through with some crazy Java errors in the log file.

     

    I just can't get by this UMP issue as it's demanding that the EMS probe is running.



  • 35.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-08-2018 12:46 PM

    Got the Java error:

     



  • 36.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-09-2018 07:33 AM

    Regarding EMS probe error, please try.

     

    1. Deactivate EMS probe.
    2. Rename "db" folder in EMS probe folder.
    3. Activate EMS probe.

     



  • 37.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-09-2018 08:41 AM

    Thanks for the suggestion, but it hasn't worked.  Still got the same error,

     

    I also tried deleting the probe entirely and deleting the ems folder completely.  I redeployed and activated but still get the same Java error as shown previously.



  • 38.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-12-2018 08:44 AM

    Having same issue with ems, deleted, repolyed, etc, exactly that error message and then max restarts



  • 39.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-14-2018 08:40 AM

    Hi,

     

    Deactivate any HA probes you have on any secondary Hubs - then try to activate the EMS probe. Surprisingly, it's worked for me!

     

    Thanks to @ttahkapaa for the tip!



  • 40.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-08-2018 01:29 PM

    How about any bug related or issues please throw into this thread so it can be found in all one place:

    *** UIM 9.x Defects/Bugs/Gotchas *** 



  • 41.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-14-2018 06:48 AM

    Hmm.. OK, update is done in my test environment, but am I missing something? In operator console there is nothing about setting up monitoring (could be the reason why it is called as Operator console) but though you can define alarming rules.

     

    So, what is the official way in UIM 9.0.2 to set up default monitoring rules for like memory usage monitoring? Basic stuff (probe deployment and QOS/threshold settings) with USM/MCS? What if then someone creates rules in operator console? There seems to be no connection between MCS and those alarm rules in OC.



  • 42.  Re: GA Announcement: CA UIM 9.0.2



  • 43.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-14-2018 08:21 AM

    Maybe it is just me, but this is a GA announcement, and not a place to put everything 9.0.2 related.

     

    To all please note many of us have a page setup showing all the open questions for UIM and this will NOT show up there. So posting a problem question here is a way to ensure it will have less visibility.



  • 44.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-14-2018 09:13 AM

    +1.. OP if you can lock this topic so that folks have to create new threads.

    If you find a new defect then throw into the defect thread.



  • 45.  Re: GA Announcement: CA UIM 9.0.2

    Posted 11-14-2018 09:29 AM

    Dear all,

    This discussion has been locked. Please use this thread to report any bugs/defects or start a new discussion if you have any issue related to this version.

     

    Thanks,

    Octavie