Layer 7 API Management

Expand all | Collapse all

Error accessing Gateway Manager via Browser

Jump to Best Answer
  • 1.  Error accessing Gateway Manager via Browser

    Posted 11-08-2018 03:04 PM

    I am trying to access the API Gateway Manager via the Browser using Firefox. I am getting the following error:

    classnotfoundexception com.I7tech.console.appletMain.com

     

    This also happen on IE



  • 2.  Re: Error accessing Gateway Manager via Browser

    Posted 11-08-2018 05:37 PM

    Dear Victor,

    It seems you were using the url like this,

    https://<gatewayHostName>:9443/ssg/webadmin

     

    If true, please be aware that applet is not supported by most of the current browsers any more.

     

    We may need to use java web start application, the link below should work,

    https://<gatewayHostName>:8443/ssg/webstart/manager.jnlp

     

    Regards,

    Mark



  • 3.  Re: Error accessing Gateway Manager via Browser
    Best Answer

    Posted 11-08-2018 09:55 PM

    Hi Victor 

     

    To follow up a bit more on Mark (He)'s answer above. 

     

    1) Alternative to running webstart programs in the browser. 

     

    As well as : in the browser access via: 

    https://<gatewayHostName>:8443/ssg/webstart/manager.jnlp

     

    You can also run webstart program directly in java via the DOS/Unix command line : 

    via : 

    javaws https://<gatewayHostName>:8443/ssg/webstart/manager.jnlp

     

    Depending on what certificate you are using on the gateway this may be all you need - it can prompt for you to trust the certificate. 

     

    2) Certificate at <gatewayHostName>:8443 not trusted 

     

    I got this blocked error :

    The error occurs for both access via the browser and via javaws direct start :  

     

     

     

    I initially thought this was because my API Gateway certificate is issued to "localhost" and the name does not match the website name (odoma04-gw.example.com that I am accessing, and that it is also a self signed cert.

     

    But it turns our the certificate used to sign the webstart .jar files expired 01-Jun-2018 : 

     

     

    I'll raise an internal case for that - this was with Gateway 9.3 I am not sure if new cert is used for 9.4 

     

    So you will need to do the following step 

     

     

    3) Making  <gatewayHostName>:8443 a "Trusted Site" 

     

    We can work around this via adding the site as a "trusted site"  via the "Configure Java" app then java will trust all webstart programs coming from that location. 

     

    3.1 So you run "Configure Java" app

    (the cmd line executable is : <JRE>\bin\"javacpl.exe")

     

     

    3.2 And you need to add the site to the exception site list : 

     

    Navigate to the security settings, and add the trusted site. 

     

    Note: I tried adding the cert as trusted, but I think there is special provision for self signed certs as well cannot be accepted for "High" security setting (even if trusted).  

     

     

    4) Running webstart from <gatewayHostName>:8443 as trusted site 

     

    Now it is a trusted site, you may still get a warning, (the error message is slightly incorred, as my cert expires in 2028, but I believe it is the "localhost" or 

     

    For the first time it will give you this exception - but then it is loaded into cache, and then after it will run without giving the warning.

     

     

    Cheers - Mark



  • 4.  Re: Error accessing Gateway Manager via Browser

    Posted 11-11-2018 10:42 AM

    Thanks for the responses!