DX Application Performance Management

Expand all | Collapse all

Command Line Workstation interactive mode

Jump to Best Answer
  • 1.  Command Line Workstation interactive mode

    Posted 06-20-2018 09:40 AM

    If I invoke Command Line Workstation in interactive mode in the following manner:
    "cat input.txt | java $MY_OPTIONS -jar CLWorkstation.jar > output.txt

     

    The output file contains the correct result for the first command contained in the input file followed by:
    "Unable to connect to the Enterprise Manager XYZ"

    input.txt:
    list agents matching (.*)Agent1(.*)
    list agents matching (.*)Agent2(.*)
    ----------------------------------------------

     

    output.txt:

    Host|Process|Agent1
    Unable to connect to the Enterprise Manager XYZ:5001

     

    DEBUG mode logging indicates that CLW is trying to connect a new Workstation instance instead of "re-using" the old connection :

    Caused by: com.wily.isengard.messageprimitives.MaxMomsExceededException: MOM connection from Node=Workstation_1223, Address=Blah, Type=socket was rejected since the clamp value of 1 has been reached

     

     

     



  • 2.  Re: Command Line Workstation interactive mode

    Posted 06-21-2018 08:42 AM

    Can someone help Richard with next steps? 



  • 3.  Re: Command Line Workstation interactive mode

    Posted 06-21-2018 11:30 PM

    Hi Richard,

    Interesting. I cannot even get that standard input method to work at all with my 10.7 CLWorkstation.jar. 

    I always get a syntax error implying I have not included a "list" option. (adding any CLW trace option like "-Dintroscope.clw.debug=true" shows no more)

    ===

    # echo $MY_OPTIONS
    -Duser=admin_local -Dhost=willy03-i2438.ca.com -Dport=5001

    # java $MY_OPTIONS -jar CLWorkstation.jar list agents matching \(.*\)Tomcat\(.*\)
    willy03-I2438|Tomcat|Tomcat Agent

    # cat input.txt
    list agents matching \(.*\)Tomcat\(.*\)
    list agents matching \(.*\)Tomcat\(.*\)

    # cat input.txt | java $MY_OPTIONS -jar CLWorkstation.jar

    Usage: java -Xmx128M <EM_logon> <Trace_props> -jar CLWorkstation.jar <Arguments>

    Where:....

    ===

     

    Hiko_Davis might have some more input.

     

    Regards,

     

    Lynn



  • 4.  Re: Command Line Workstation interactive mode
    Best Answer

    Posted 06-22-2018 12:01 AM

    Hi Richard,

    Did you leave off "-i" from your command in your original post?

    Sorry my bad I had not used the interactive mode "-i" option before and with that added I now have it working and I am seeing the expected 2 results:

    # echo $MY_OPTIONS
    -Duser=admin_local -Dhost=willy03-i2438.ca.com -Dport=5001

    # cat input.txt
    list agents matching .*EPAgent.*
    list agents matching .*Tomcat.*

    # cat input.txt | java $MY_OPTIONS -jar CLWorkstation.jar -i
    willy03-I2438|EPAgentProcess|EPAgent
    willy03-I2438|Tomcat|Tomcat Agent

     

    I can only find "Caused by: com.wily.isengard.messageprimitives.MaxMomsExceededException: MOM connection from Node=Workstation...." previously reported for MOM-Collector handshake connection failures.

    I am using a standalone EM and not a cluster, but will try to test on that next.

     

    Regards,

     

    Lynn



  • 5.  Re: Command Line Workstation interactive mode

    Posted 06-26-2018 02:46 AM

    Hi Richard,

    I tested with a 10.7 mini cluster and I am still not seeing a problem when connecting to the MOM

    CLW DEBUG ("-Dintroscope.clw.debug=true") output below shows it is does create a separate socket connection/workstation session for each line of standard input:

    ===

    6/26/18 12:00:41 PM IST [DEBUG] [CLW.IsengardMessaging] Creating http tunneling client socket factory.
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.IsengardMessaging] Creating default client socket factory.
    6/26/18 12:00:41 PM IST [DEBUG] [CLW] Do not set Send/Receive Buffer Size. Keep original values: 9900/43690
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.OutgoingConnection] Established client connection: host: /10.131.237.191, port: 5001, socket send buffer size [bytes]: 9900, socket receive buffer size [bytes]: 43690
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.PostOfficeHub] Transport up: Socket Transport connected with Socket[addr=/10.131.237.191,port=5001,localport=39776]
    6/26/18 12:00:41 PM IST [VERBOSE] [CLW.PostOfficeHub] Connected To: Node=Server, Address=/10.131.237.191:5001, Type=socket
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.PostOfficeHub] Hub name set to: Workstation_15
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.PostOfficeHub] Transport up: Loopback PO: Workstation_15.client_main
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.PostOffice] PostOffice: Workstation_15.client_main created.
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.IsengardClient] Number of client po threads 3
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.IsengardClient] Client successfully connected with Isengard server.
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.BeanContainerCore] Bean container 'Workstation_15' activated
    willy03-I2438|EPAgentProcess|EPAgent
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.IsengardMessaging] Creating http tunneling client socket factory.
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.IsengardMessaging] Creating default client socket factory.
    6/26/18 12:00:41 PM IST [DEBUG] [CLW] Do not set Send/Receive Buffer Size. Keep original values: 9900/43690
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.OutgoingConnection] Established client connection: host: /10.131.237.191, port: 5001, socket send buffer size [bytes]: 9900, socket receive buffer size [bytes]: 43690
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.PostOfficeHub] Transport up: Socket Transport connected with Socket[addr=/10.131.237.191,port=5001,localport=39778]
    6/26/18 12:00:41 PM IST [VERBOSE] [CLW.PostOfficeHub] Connected To: Node=Server, Address=/10.131.237.191:5001, Type=socket
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.PostOfficeHub] Hub name set to: Workstation_16
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.PostOfficeHub] Transport up: Loopback PO: Workstation_16.client_main
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.PostOffice] PostOffice: Workstation_16.client_main created.
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.IsengardClient] Number of client po threads 3
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.IsengardClient] Client successfully connected with Isengard server.
    6/26/18 12:00:41 PM IST [DEBUG] [CLW.BeanContainerCore] Bean container 'Workstation_16' activated
    willy03-I2438|Tomcat|Tomcat Agent

    ===

     

    I see similar in the EM log with the first Workstation session being logged out before the 2nd one is started:

    ===

    6/26/18 12:00:39.774 PM IST [DEBUG] [PO:main Mailman 4] [Manager.SessionBean] User "admin_local" logged in successfully from host "Node=Workstation_15, Address=willy03-i2490.ca.com/10.131.237.169:39776, Type=socket"
    6/26/18 12:00:39.774 PM IST [INFO] [PO:main Mailman 4] [Manager.SessionBean] Command Line Work Station User "admin_local" connected successfully from host "Node=Workstation_15, Address=willy03-i2490.ca.com/10.131.237.169:39776, Type=socket"
    6/26/18 12:00:39.859 PM IST [DEBUG] [PO:main Mailman 8] [Manager.SessionBean] Logging out user "admin_local" from host "Node=Workstation_15, Address=willy03-i2490.ca.com/10.131.237.169:39776, Type=socket"
    ...
    6/26/18 12:00:39.913 PM IST [DEBUG] [PO:main Mailman 3] [Manager.SessionBean] User "admin_local" logged in successfully from host "Node=Workstation_16, Address=willy03-i2490.ca.com/10.131.237.169:39778, Type=socket"
    6/26/18 12:00:39.913 PM IST [INFO] [PO:main Mailman 3] [Manager.SessionBean] Command Line Work Station User "admin_local" connected successfully from host "Node=Workstation_16, Address=willy03-i2490.ca.com/10.131.237.169:39778, Type=socket"
    6/26/18 12:00:39.940 PM IST [DEBUG] [PO:main Mailman 4] [Manager.SessionBean] Logging out user "admin_local" from host "Node=Workstation_16, Address=willy03-i2490.ca.com/10.131.237.169:39778, Type=socket"

    ===

     

    So CLW starting a separate Workstation session for each line of input is the correct behaviour, but I cannot explain why you are having a problem starting the 2nd Workstation session.

    If this important for you please create a support case and refer to this thread so we can investigate further.

     

    Thanks

     

    Lynn