Automic Workload Automation

Expand all | Collapse all

AWI/UI agent status

  • 1.  AWI/UI agent status

    Posted 06-28-2018 05:21 PM

    Hi All,

    hope all is well

    I came across an issue where in even when the agent is running, on System Overview/Administration tab, the icon looks to be grayed out.

     

    where in all the other agents behave fine.

    Anyone faced the same or if anyone has some solution to it, it will be great.

     

    Thanks

    Shani



  • 2.  Re: AWI/UI agent status

    Posted 06-28-2018 05:34 PM

    Hey Shani,

     

    What I would assume is happening is the process ID listed for that agent in the service manager dialog is active on the Agent server but it is not communicating with the CP. I would look at the Agent log on the server to get more information.

     

    You might need to stop the Agent from the service manager dialog if possible or worst case kill the PID for that Agent and restart it from the UI or smgr



  • 3.  Re: AWI/UI agent status

    Posted 06-28-2018 06:12 PM

    HI Mike,

    I tried the steps but with no good.

    (You might need to stop the Agent from the service manager  (Done with no good)dialog if possible or worst case kill the PID for that Agent and restart it from the UI or smgr(Tried this too).

     

    now the agent doesn't start from the SM dialog or AWI.

    attaching the logs and screenshots

     

     

    Attachment(s)



  • 4.  Re: AWI/UI agent status

    Posted 06-28-2018 07:05 PM

    This is the error you are getting:

     

    Windows agent aborts during Filetransfer of large file 

     

    Is there any chance you have a filetransfer in AE that is waiting for host rhq2k12ap12?



  • 5.  Re: AWI/UI agent status

    Posted 06-29-2018 11:07 AM

    there is no major file transfers for now. I tried to restart the agent and got below error in the SM.

    20180629/095240.136 - U00022023 No associated window can be found for process 'UC4 WIN01'.
    20180629/095240.160 - U00022012 Process 'UC4 WIN01' (ID '1200') ended.
    20180629/095240.160 - U00022042 Process 'UC4 WIN01' abnormal ended with access violation.

     

    and below was for Agent.

     

    20180629/100455.666 - U02000234 Thread '11284' for Run ID '1530234' started.
    20180629/100455.710 - U02000135 Thread '11284' ended.
    20180629/100515.594 - U02000234 Thread '14612' for Run ID '1533348' started.
    20180629/100515.642 - U02000135 Thread '14612' ended.
    20180629/100535.449 - U02000234 Thread '12020' for Run ID '1535369' started.
    20180629/100535.493 - U02000135 Thread '12020' ended.
    20180629/100555.664 - U02000234 Thread '12468' for Run ID '1530234' started.
    20180629/100555.708 - U02000135 Thread '12468' ended.
    20180629/100615.677 - U02000234 Thread '14516' for Run ID '1533348' started.
    20180629/100615.720 - U02000135 Thread '14516' ended.
    20180629/100635.458 - U02000234 Thread '13904' for Run ID '1535369' started.
    20180629/100635.503 - U02000135 Thread '13904' ended.



  • 6.  Re: AWI/UI agent status

    Posted 06-29-2018 11:20 AM

    And Windows Task Manager shows both SM and Agent to be running.