Service Virtualization

Expand all | Collapse all

How to turn off SSL certificate validation?

Jump to Best Answer
  • 1.  How to turn off SSL certificate validation?

    Posted 06-06-2018 04:21 PM

    I have a https REST api which doesn't have any authorization. It works fine in postman when I turn off the SSL Certification Validation. Is there a way to turn off in DevTest?



  • 2.  Re: How to turn off SSL certificate validation?
    Best Answer

    Posted 06-06-2018 04:27 PM

    Hi Tushar,

     

    DevTest does not perform any validation of the host certificate.  You won't need to do anything.

     

    --Mike



  • 3.  Re: How to turn off SSL certificate validation?

    Posted 06-07-2018 09:10 AM

    I am getting this error when I am trying curl 

     

    error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure



  • 4.  Re: How to turn off SSL certificate validation?

    Posted 06-07-2018 11:26 AM

    Is the remote server performing client authentication (also called 2-way SSL)?  You may need to provide a client certificate.

     

    Also, try this: In Workstation, go to Help -> HTTP/SSL Debug.  This will open a debug window detailing the handshake process.  This will indicate more precisely why the failure is occurring.

     

    --Mike



  • 5.  Re: How to turn off SSL certificate validation?

    Posted 06-07-2018 11:44 AM

    Here's something else to try.  Put this in local.properties:

     

    https.protocols=SSLv3

     

    By default, DevTest is configured to use all versions of SSL.  The server might be rejecting the one DevTest selects.  The above setting causes DevTest to always use v3.

     

    https://docops.ca.com/devtest-solutions/10-4/en/administering/security/ssl-tls-protocol-configuration 

     

    --Mike