Layer7 Privileged Access Management

Expand all | Collapse all

CA PAM version 3.1 supported browser versions

Jump to Best Answer
  • 1.  CA PAM version 3.1 supported browser versions

    Posted 07-11-2018 06:11 AM

    Hi,

     

    We are using CA PAM 3.1.1.71 version. The CA PAM application works fine from some of the users desktops using Internet Explorer 11.

     

    But for some other users it does not work the applet was loading and loading but not showing and for some users its hung. These users also having IE 11.

     

    We want to know:

    1. What are the JAVA prerequisites from End user's desktop or laptop

    2. What are browsers and version supported [Example: IE 11, Chrome, Mozilla]

     

    Kindly help. 

     

    Thanks

    dk



  • 2.  Re: CA PAM version 3.1 supported browser versions
    Best Answer

    Posted 07-11-2018 03:03 PM

    Hi Dk, You find this information in our platform support matrix at https://support.ca.com/phpdocs/7/9526/9526-PAM-platformsupportmatrix.pdf in section 3:

     

    From January 1st 2017, the only browser option is Microsoft Internet Explorer 11 (the only browser still with NPAPI support which is required for the applets). If using IE11, Java 8u-latest must be installed on the desktop (Oracle Java 7 is EoL for public updates).



  • 3.  Re: CA PAM version 3.1 supported browser versions

    Posted 07-20-2018 12:12 AM
    Hi,
    My customer has the below concern. My customer has recently read in an article posted by Oracle that they are going to mark the java Applet class as deprecated in JDK 9. 
    In this case, how CA PAM will be supporting for JAVA 9 version and going forward.
    What is the Plan from CA for java applet deprecation in Java 9?
    Is there any plan to use any alternate method in CA PAM?
    Also, He raises below concern:
    As per the organization security reasons, the end users will not have admin rights on their laptop and desktop. In this case how do they install PAM client? OR Required JAVA version ?
    DO we require to ask all end users to bring their laptops to sysadmin team and install the CA PAM supported version of JAVA?
    -dk


  • 4.  Re: CA PAM version 3.1 supported browser versions

     
    Posted 07-20-2018 06:40 AM

    You should be able to install the PAM Client with just standard user rights.

    The PAM client includes a bundled version of the JRE, so no need to install Java.



  • 5.  Re: CA PAM version 3.1 supported browser versions

    Posted 07-23-2018 02:08 PM

    In addition to IE 11, the Known Issues section in DocOps for v3.1.1 states "Firefox versions 52 and later do not support NPAPI" and implies versions earlier than v52 are supported. Known Issues - CA Privileged Access Manager - 3.1.1 - CA Technologies Documentation 

     

    Christo



  • 6.  Re: CA PAM version 3.1 supported browser versions

    Posted 07-23-2018 02:19 PM

    FireFox 52 ESR version can be used with CAPAM, and has been tested and used by some of our customers.