Clarity PPM

Expand all | Collapse all

Attribute hints not showing after XOG write

  • 1.  Attribute hints not showing after XOG write

    Posted 06-20-2018 04:12 AM

    made some changes in a DEV environment to a object and view (added attributes, placed and removed attributes in the view, adding attribute hints).  I XOG'ed out the object, then XOG'ed it into the UAT environment (over the existing object) to update it.  the new attributes were created.  the attribute placement on the edit layouts were fine.  but the attribute hints are not showing up in the UAT environment.  

    I go into View / Fields and looked at the attributes in questions and the ToolTips property is blank.

    but when i go into the database and look at CMN_CAPTIONS_NLS, i find the exact ToolTip text in the table (it's the only place this particular string is used).  so the text is there, but it's not displaying.

     

    Anyone seen this behavior before?  

    Any thoughts on what's causing it or how to fix it?

    Thanks

    B



  • 2.  Re: Attribute hints not showing after XOG write

    Posted 06-20-2018 05:49 AM

    "how to fix it" - just (manually) copy the tool tip into the configuration in your UAT environment?



  • 3.  Re: Attribute hints not showing after XOG write

    Posted 06-20-2018 03:40 PM

    Yeah, i was hoping to avoid a manual fix.  XOG is supposed to reliably write what it reads, and the ToolTips are in the XML that was read out.  It would be nice to know why it's not working



  • 4.  Re: Attribute hints not showing after XOG write

    Posted 06-20-2018 11:39 PM

    Check if odf_view_attributes.tip is null / empty for these attributes.

     

    If so that would be my guess as to why, and the only non-manual fix would then be to perform a table update on odf_view_attributes and back-port the entries from CMN_CAPTIONS_NLS into it (for one of the languages) and restart apps / flush caches.

     

    Manual fix is of course preferred by being a supportable solution, and probably the only one.

     

    It is also not given as an assurance that XOG will write everything that it reads - some data isn't bi-directional by design - but in this case I'd lean towards it being a defect and would get it reported as such if it persists and can be reproduced on other systems.