DX Application Performance Management

Expand all | Collapse all

Introscope 10.5.2 SP2 wMIS Agent showing 'null' metric

Jump to Best Answer
  • 1.  Introscope 10.5.2 SP2 wMIS Agent showing 'null' metric

    Posted 05-11-2018 02:31 PM

    I've installed APM Introscope 10.5.2 SP2 Java Agent on webMethods Integration Server v9.5. Once it was instrumented, I saw the following metrics labeled "null"...

     

     

    But this metric is NOT present in my other APM Introscope Agent v10.1 on a similar wMIS9.5 on another server.

     

    Thanks in advance for any/all help.

     

    Thanks,

    Manish



  • 2.  Re: Introscope 10.5.2 SP2 wMIS Agent showing 'null' metric

    Posted 05-11-2018 02:36 PM

    This ERROR gets logged repeatedly and has filled up 4 diff logfiles

     

    5/11/18 02:33:14 PM EDT [ERROR] [IntroscopeAgent.Agent] An error occurred formatting jms client metric namenull
    5/11/18 02:33:14 PM EDT [ERROR] [IntroscopeAgent.Agent] An error occurred formatting jms client metric namenull
    5/11/18 02:33:14 PM EDT [ERROR] [IntroscopeAgent.Agent] Exception starting method tracer com.wily.introscope.agent.trace.frontend.jms.JMSFrontendTracer actual trace for com.webmethods.rtl.event.RemoteDeliverer.onMessage
     



  • 3.  Re: Introscope 10.5.2 SP2 wMIS Agent showing 'null' metric

    Posted 05-13-2018 09:20 AM

    Dear Manish:

         This appears to be a known issue. In that thread, it was suggested to open a case . For this particular issue, there is only so much that can be done through the Community. So opening a case and ending this thread seems the best way. If you find a solution with 10.5.2, please share with others that may have identical issues.

     

    10.5.1.8 and 10.5.2 SP2 Agent Issue solved installing 10.7.0.45 Agent   



  • 4.  Re: Introscope 10.5.2 SP2 wMIS Agent showing 'null' metric

    Posted 05-14-2018 11:19 AM

    We would need the agent log in DEBUG to see into this, this is a common issue with JMS monitoring since we changed the monitoring in 10.3 agent. The original implementation of the monitoring expected to be able to pick out data from the JMS message header, but it appears that this field is not being used as much as was expected.

    10.7 may fix some issues but not necessarily for every platform.



  • 5.  Re: Introscope 10.5.2 SP2 wMIS Agent showing 'null' metric

    Posted 05-14-2018 02:16 PM

    DavidLewis

    So, upgrading to v10.7.0.45 is not an option b/c I just upgraded the infratructure from v10.1 to v10.5.2 SP2. I've opened up case 01084936 w/ CA Support. It would be great if you can provide assistance.

     

    I've uploaded most all that would be required for analysis to look into this issue. If you need more then I'd be more than happy to upload it, just let me know.

     

    Thanks,

    Manish



  • 6.  Re: Introscope 10.5.2 SP2 wMIS Agent showing 'null' metric
    Best Answer

    Posted 05-18-2018 12:46 PM

    I have a fix for this issue...

     

    Apparently there is a known defect for JMX null node issue which was NOT generating metrics if JMSDestination was not available in the JMS header. 

     

    The 2 jar files supplied to me as a part of the hot fix (2HF29_DE337981)

     

    Agent.jar

    Backendprotocols.jar

     

    Copy "Agent.jar" file to 'wily' dir (renaming the old one to something else)

    Copy "Backendprotocols.jar" file to 'wily/core/ext' dir (renaming the old one to something else)

    Restart the app server.

     

    After restarting the app server, you should see the following entry showing "Build 992900"

     

    5/14/18 05:25:04 PM EDT [INFO] [IntroscopeAgent.Agent] Agent Release 10.5.2.78 (Build 992900)

     

    This resolves the "null" metrics issue.

     

    Thanks jAmEs_shIn & huaba01

     

    Hallett_German - Please mark this reply as "Correct Answer"