DX Application Performance Management

Expand all | Collapse all

Performace Probleam APM 10.5.1.8

Jump to Best Answer
  • 1.  Performace Probleam APM 10.5.1.8

    Posted 11-29-2018 10:09 AM

    In my APM console shows me that I have many of my collectors with Introscope.agent.metricClamp with a value of 10000. I also have high numbers in traces in the collectors. How can i fix this?
    What are the values that I should configure in my collectors to support these values?

     

    Thanks Marcelo



  • 2.  Re: Performace Probleam APM 10.5.1.8

    Posted 11-29-2018 10:39 AM

    CheloLabonia
    Problem might be from agent side. You have to find out what metrics are causing this clamp problem. check SQL queries, deep instrumentation etc. What agent version are you using?

    I found similar discussion in  CA Community take a look

     

    https://communities.ca.com/message/241998332-clamped-agent



  • 3.  Re: Performace Probleam APM 10.5.1.8

    Posted 11-29-2018 11:41 AM
    Junaidwily, Ok I will read your recommending. Thank you so much


  • 4.  Re: Performace Probleam APM 10.5.1.8
    Best Answer

    Posted 11-29-2018 10:50 AM

    Hi Marcelo,

     

     

    Although you can keep increase increasing the default agent clamps (introscope.agent.transactiontrace.componentCountClamp, introscope.agent.metricClamp) , EM clamps and probably split the load by adding more collectors to support the metric load


    I suggest to review your agent configuration and try to reduce the agent configuration / instrumentation, do you really need all the metrics?

     

    See:

    Agent Deployment Guidelines - CA Application Performance Management - 10.7 - CA Technologies Documentation 

    apm-events-thresholds-config.xml - CA Application Performance Management - 10.7 - CA Technologies Documentation 

     

    I suggest you to review this KB, I have tried to compiled most of the common EM configuration issues causing performance issues.

    Introscope Enterprise Manager Troubleshooting and - CA Knowledge 

     

    Finally, you are using an old release, we have made several enhancements to the server components, I strongly suggest you to consider to upgrade to the latest 10.7 build

     

    I hope this helps,

    Sergio



  • 5.  Re: Performace Probleam APM 10.5.1.8

    Posted 11-29-2018 11:41 AM
    Sergio, Ok I will read your recommending. Thank you so much