DX Infrastructure Management

Expand all | Collapse all

How to clear queue inactive informational alert ?

  • 1.  How to clear queue inactive informational alert ?

    Posted 12-07-2018 03:07 AM

    Suppose we have 4 hubs H1_1(primary) H1_2(secondary for failover) and H2_1(primary) H2_2(secondary for failover).

    We have attach queues for alarm and qos data from  H2_1 and H2_2 to both H1_1 and H1_2 hubs and get queue in boths hubs H1_1 and H1_2. 

    As of now H1_1 and H2_1 are communicating properly. Get and attach queue are disabled for both secondary hubs H1_2 and H2_2.

    We are getting informational alert that queue_H2_2data,queue_H2_2_qos  queue is disabled which is fine as they are not failover.

    We want to clear these alerts form UIM console so that these alerts are not forwaded to moogsoft side(event management tool).

     



  • 2.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 04:10 AM

    Hi, can you copy here what exact alarms you are getting ?



  • 3.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 04:50 AM

    'Queue HUB1_1 _HUB2_2_qos failed to connect to hub'

    'Queue HUB1_1 _HUB2_2_alarm failed to connect to hub'

    Queue HUB2_1 _HUB1_2_alarm failed to connect to hub'

     

    Also, from where we can set severity level of these type of alerts ?



  • 4.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 05:00 AM
      |   view attached

    The alarms does not disappear as long as queue connection gets established.

    NOTE - One ATTACH queue can not establish connection with multiple GET queues at one time.

     

    About severity, no config to change severity of queue disconnection alarm.

    If you want to do, here is a sample LUA script that does change severity to critical.

     

     

    Attachment(s)



  • 5.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 05:01 AM

    Sorry. Typo.

    The alarm does not disappear as long as queue connection is not established.



  • 6.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 05:15 AM

    Since failover not occured, queues of secondary hubs is not activated, so alarm is thrown.

    But we do not want these alarms.

    How does UIM decides that severity of this type of alarm 'Queue HUB1_1 _HUB2_2_qos failed to connect to hub' is informational. May be from there we can tweak some settings. 

    We have one get queue for every attach queue, so that is not a concern.

     



  • 7.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 05:18 AM

    Also, when i right click this alert, there is a option for "Hold Alarms", what is this option for, will it work ?



  • 8.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 06:51 AM

    Hold alarm does not help in this case.



  • 9.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 06:45 AM

    It looks that ATTACH queue is not active ? - so your GET queue does not work.

    The severity of the alarm is hard-coded and not configurable, sorry.



  • 10.  Re: How to clear queue inactive informational alert ?

    Posted 12-07-2018 07:06 AM

    Right, attach queue of secondary hub is not active.

    It will active only when failover happens and secondary hub takes over primary hub, which is automatic process.



  • 11.  Re: How to clear queue inactive informational alert ?

    Posted 12-09-2018 10:36 PM

    Is there any reason attach queue of secondary hub inactive ?

     



  • 12.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 02:22 AM

    it is inactive because its primary hub is up and running, secondary hub will be up when there is failover, i.e. when its primary hub goes down and then attach queues of secondary hubs (one queue for alarms and another for qos messages) will activate automatically. 

    We have unticked the boxes of attach queues in secondary hub.

    If we tick/enable the attach queues of secondary hub, will the alert be generated in this case also ?



  • 13.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 02:29 AM

    Thank you for response.

    If that's the case, you might want to use HA probe in secondary hub so HA probe will turn GET queue on upon failover senario.



  • 14.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 02:41 AM

    We already have HA probe in sencondary hub.

    So by enabling attach queue in secondary hub ,alerts of this type should not be generated, right ?



  • 15.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 02:47 AM

    Add your attach queue into "Queue to enable" section in HA probe, so that it gets activated only failover situation.



  • 16.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 02:57 AM

    Attach queues in "queue to enable" are added.



  • 17.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 03:01 AM

    Thanks. So the attach queue (in secondary hub) is inactive as long as primary hub is healthy. The attach queue will be activated upon only primary hub is down.

     



  • 18.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 03:06 AM

    Yes, right.

    Now, if we tick the attach queues in secondary hub, queue inactive alerts should be gone ? Right ? 

    Withouth having impact on normal functioning of UIM.



  • 19.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 03:19 AM

    You are correct.



  • 20.  Re: How to clear queue inactive informational alert ?

    Posted 12-10-2018 05:24 AM

    Thank YU !